Public bug reported:

Done a fresh wine-development install on Yakkety 64 bits with a gnome-
shell session

but:
- there is no warning/error while doing the wine install (except it remove 
gnome-disk-utility and squasfs-tools which can be reinstalled after without 
problem.)
- wincfg is not present into the wine menu (from Applications topbar menu)
- wine-gecko is not installed by default (see warning at this end of report)
- and get lot of dependencies issues:

oem@u64:~$ wine winecfg
it looks like wine32-development is missing, you should install it.
as root, please execute "apt-get install wine32-development"
wine: created the configuration directory '/home/oem/.wine'
err:ole:marshal_object couldn't get IPSFactory buffer for interface 
{00000131-0000-0000-c000-000000000046}
err:ole:marshal_object couldn't get IPSFactory buffer for interface 
{6d5140c1-7436-11ce-8034-00aa006009fa}
err:ole:StdMarshalImpl_MarshalInterface Failed to create ifstub, hres=0x80004002
err:ole:CoMarshalInterface Failed to marshal the interface 
{6d5140c1-7436-11ce-8034-00aa006009fa}, 80004002
err:ole:get_local_server_stream Failed: 80004002
err:ole:marshal_object couldn't get IPSFactory buffer for interface 
{00000131-0000-0000-c000-000000000046}
err:ole:marshal_object couldn't get IPSFactory buffer for interface 
{6d5140c1-7436-11ce-8034-00aa006009fa}
err:ole:StdMarshalImpl_MarshalInterface Failed to create ifstub, hres=0x80004002
err:ole:CoMarshalInterface Failed to marshal the interface 
{6d5140c1-7436-11ce-8034-00aa006009fa}, 80004002
err:ole:get_local_server_stream Failed: 80004002
Could not load wine-gecko. HTML rendering will be disabled.
it looks like wine32-development is missing, you should install it.
as root, please execute "apt-get install wine32-development"
Could not load wine-gecko. HTML rendering will be disabled.
wine: configuration in '/home/oem/.wine' has been updated.

oem@u64:~$ sudo apt-get install wine32-development
[sudo] password for oem:
Reading package lists... Done
Building dependency tree
...

The following information may help to resolve the situation:

The following packages have unmet dependencies.
 wine32-development:i386 : Depends: libwine-development:i386 (= 
1.9.20-1ubuntu1) but it is not going to be installed
E: Unable to correct problems, you have held broken packages. # no broken 
package but the wine

oem@u64:~$ sudo apt-get install libwine-development:i386
...
The following information may help to resolve the situation:

The following packages have unmet dependencies.
 libwine-development:i386 : Depends: libldap-2.4-2:i386 (>= 2.4.7) but it is 
not going to be installed
                            Depends: libpulse0:i386 (>= 0.99.1) but it is not 
going to be installed
                            Depends: libxml2:i386 (>= 2.9.0) but it is not 
going to be installed
                            Recommends: libcups2:i386 (>= 1.4.0) but it is not 
going to be installed
                            Recommends: libdbus-1-3:i386 (>= 1.9.14) but it is 
not going to be installed
                            Recommends: libtiff5:i386 (>= 4.0.3) but it is not 
going to be installed
                            Recommends: libxslt1.1:i386 (>= 1.1.25) but it is 
not going to be installed
                            Recommends: libasound2-plugins:i386 but it is not 
going to be installed
E: Unable to correct problems, you have held broken packages.

note: wine64-development is installed, but the wine32-development is
missing into the archive; only have a wine32-development-preloader:i386
which also fail to install

Could it be a multiarch problem with some dependencies ?

That is: no way to use wine on yakkety 64 bits; these issues are not met
with xenial 64 bits & the same wine version with a gnome-shell session
too.

ProblemType: Bug
DistroRelease: Ubuntu 16.10
Package: wine-development 1.9.20-1ubuntu1
ProcVersionSignature: Ubuntu 4.8.0-22.24-generic 4.8.0
Uname: Linux 4.8.0-22-generic x86_64
NonfreeKernelModules: nvidia_uvm nvidia_drm nvidia_modeset nvidia
ApportVersion: 2.20.3-0ubuntu8
Architecture: amd64
CurrentDesktop: GNOME
Date: Wed Oct 12 18:41:12 2016
PackageArchitecture: all
SourcePackage: wine-development
UpgradeStatus: No upgrade log present (probably fresh install)

** Affects: wine-development (Ubuntu)
     Importance: Undecided
         Status: New


** Tags: amd64 apport-bug third-party-packages yakkety

** Description changed:

  Done a fresh wine-development install on Yakkety 64 bits with a gnome-
  shell session
  
  but:
  - there is no warning/error while doing the wine install (except it remove 
gnome-disk-utility and squasfs-tools which can be reinstalled after without 
problem.)
  - wincfg is not present into the wine menu (from Applications topbar menu)
+ - wine-gecko is not installed by default (see warning at this end of report)
  - and get lot of dependencies issues:
- 
  
  oem@u64:~$ wine winecfg
  it looks like wine32-development is missing, you should install it.
  as root, please execute "apt-get install wine32-development"
  wine: created the configuration directory '/home/oem/.wine'
  err:ole:marshal_object couldn't get IPSFactory buffer for interface 
{00000131-0000-0000-c000-000000000046}
  err:ole:marshal_object couldn't get IPSFactory buffer for interface 
{6d5140c1-7436-11ce-8034-00aa006009fa}
  err:ole:StdMarshalImpl_MarshalInterface Failed to create ifstub, 
hres=0x80004002
  err:ole:CoMarshalInterface Failed to marshal the interface 
{6d5140c1-7436-11ce-8034-00aa006009fa}, 80004002
  err:ole:get_local_server_stream Failed: 80004002
  err:ole:marshal_object couldn't get IPSFactory buffer for interface 
{00000131-0000-0000-c000-000000000046}
  err:ole:marshal_object couldn't get IPSFactory buffer for interface 
{6d5140c1-7436-11ce-8034-00aa006009fa}
  err:ole:StdMarshalImpl_MarshalInterface Failed to create ifstub, 
hres=0x80004002
  err:ole:CoMarshalInterface Failed to marshal the interface 
{6d5140c1-7436-11ce-8034-00aa006009fa}, 80004002
  err:ole:get_local_server_stream Failed: 80004002
  Could not load wine-gecko. HTML rendering will be disabled.
  it looks like wine32-development is missing, you should install it.
  as root, please execute "apt-get install wine32-development"
  Could not load wine-gecko. HTML rendering will be disabled.
  wine: configuration in '/home/oem/.wine' has been updated.
  
- 
  oem@u64:~$ sudo apt-get install wine32-development
- [sudo] password for oem: 
+ [sudo] password for oem:
  Reading package lists... Done
- Building dependency tree       
- ... 
+ Building dependency tree
+ ...
  
  The following information may help to resolve the situation:
  
  The following packages have unmet dependencies.
-  wine32-development:i386 : Depends: libwine-development:i386 (= 
1.9.20-1ubuntu1) but it is not going to be installed
+  wine32-development:i386 : Depends: libwine-development:i386 (= 
1.9.20-1ubuntu1) but it is not going to be installed
  E: Unable to correct problems, you have held broken packages. # no broken 
package but the wine
- 
  
  oem@u64:~$ sudo apt-get install libwine-development:i386
  ...
  The following information may help to resolve the situation:
  
  The following packages have unmet dependencies.
-  libwine-development:i386 : Depends: libldap-2.4-2:i386 (>= 2.4.7) but it is 
not going to be installed
-                             Depends: libpulse0:i386 (>= 0.99.1) but it is not 
going to be installed
-                             Depends: libxml2:i386 (>= 2.9.0) but it is not 
going to be installed
-                             Recommends: libcups2:i386 (>= 1.4.0) but it is 
not going to be installed
-                             Recommends: libdbus-1-3:i386 (>= 1.9.14) but it 
is not going to be installed
-                             Recommends: libtiff5:i386 (>= 4.0.3) but it is 
not going to be installed
-                             Recommends: libxslt1.1:i386 (>= 1.1.25) but it is 
not going to be installed
-                             Recommends: libasound2-plugins:i386 but it is not 
going to be installed
+  libwine-development:i386 : Depends: libldap-2.4-2:i386 (>= 2.4.7) but it is 
not going to be installed
+                             Depends: libpulse0:i386 (>= 0.99.1) but it is not 
going to be installed
+                             Depends: libxml2:i386 (>= 2.9.0) but it is not 
going to be installed
+                             Recommends: libcups2:i386 (>= 1.4.0) but it is 
not going to be installed
+                             Recommends: libdbus-1-3:i386 (>= 1.9.14) but it 
is not going to be installed
+                             Recommends: libtiff5:i386 (>= 4.0.3) but it is 
not going to be installed
+                             Recommends: libxslt1.1:i386 (>= 1.1.25) but it is 
not going to be installed
+                             Recommends: libasound2-plugins:i386 but it is not 
going to be installed
  E: Unable to correct problems, you have held broken packages.
  
  That is: no way to use wine on yakkety 64 bits; these issues are not met
  with xenial 64 bits & the same wine version with a gnome-shell session
  too.
  
  ProblemType: Bug
  DistroRelease: Ubuntu 16.10
  Package: wine-development 1.9.20-1ubuntu1
  ProcVersionSignature: Ubuntu 4.8.0-22.24-generic 4.8.0
  Uname: Linux 4.8.0-22-generic x86_64
  NonfreeKernelModules: nvidia_uvm nvidia_drm nvidia_modeset nvidia
  ApportVersion: 2.20.3-0ubuntu8
  Architecture: amd64
  CurrentDesktop: GNOME
  Date: Wed Oct 12 18:41:12 2016
  PackageArchitecture: all
  SourcePackage: wine-development
  UpgradeStatus: No upgrade log present (probably fresh install)

** Description changed:

  Done a fresh wine-development install on Yakkety 64 bits with a gnome-
  shell session
  
  but:
  - there is no warning/error while doing the wine install (except it remove 
gnome-disk-utility and squasfs-tools which can be reinstalled after without 
problem.)
  - wincfg is not present into the wine menu (from Applications topbar menu)
  - wine-gecko is not installed by default (see warning at this end of report)
  - and get lot of dependencies issues:
  
  oem@u64:~$ wine winecfg
  it looks like wine32-development is missing, you should install it.
  as root, please execute "apt-get install wine32-development"
  wine: created the configuration directory '/home/oem/.wine'
  err:ole:marshal_object couldn't get IPSFactory buffer for interface 
{00000131-0000-0000-c000-000000000046}
  err:ole:marshal_object couldn't get IPSFactory buffer for interface 
{6d5140c1-7436-11ce-8034-00aa006009fa}
  err:ole:StdMarshalImpl_MarshalInterface Failed to create ifstub, 
hres=0x80004002
  err:ole:CoMarshalInterface Failed to marshal the interface 
{6d5140c1-7436-11ce-8034-00aa006009fa}, 80004002
  err:ole:get_local_server_stream Failed: 80004002
  err:ole:marshal_object couldn't get IPSFactory buffer for interface 
{00000131-0000-0000-c000-000000000046}
  err:ole:marshal_object couldn't get IPSFactory buffer for interface 
{6d5140c1-7436-11ce-8034-00aa006009fa}
  err:ole:StdMarshalImpl_MarshalInterface Failed to create ifstub, 
hres=0x80004002
  err:ole:CoMarshalInterface Failed to marshal the interface 
{6d5140c1-7436-11ce-8034-00aa006009fa}, 80004002
  err:ole:get_local_server_stream Failed: 80004002
  Could not load wine-gecko. HTML rendering will be disabled.
  it looks like wine32-development is missing, you should install it.
  as root, please execute "apt-get install wine32-development"
  Could not load wine-gecko. HTML rendering will be disabled.
  wine: configuration in '/home/oem/.wine' has been updated.
  
  oem@u64:~$ sudo apt-get install wine32-development
  [sudo] password for oem:
  Reading package lists... Done
  Building dependency tree
  ...
  
  The following information may help to resolve the situation:
  
  The following packages have unmet dependencies.
   wine32-development:i386 : Depends: libwine-development:i386 (= 
1.9.20-1ubuntu1) but it is not going to be installed
  E: Unable to correct problems, you have held broken packages. # no broken 
package but the wine
  
  oem@u64:~$ sudo apt-get install libwine-development:i386
  ...
  The following information may help to resolve the situation:
  
  The following packages have unmet dependencies.
   libwine-development:i386 : Depends: libldap-2.4-2:i386 (>= 2.4.7) but it is 
not going to be installed
                              Depends: libpulse0:i386 (>= 0.99.1) but it is not 
going to be installed
                              Depends: libxml2:i386 (>= 2.9.0) but it is not 
going to be installed
                              Recommends: libcups2:i386 (>= 1.4.0) but it is 
not going to be installed
                              Recommends: libdbus-1-3:i386 (>= 1.9.14) but it 
is not going to be installed
                              Recommends: libtiff5:i386 (>= 4.0.3) but it is 
not going to be installed
                              Recommends: libxslt1.1:i386 (>= 1.1.25) but it is 
not going to be installed
                              Recommends: libasound2-plugins:i386 but it is not 
going to be installed
  E: Unable to correct problems, you have held broken packages.
  
+ note: wine64-development is installed, but the wine32-development is
+ missing into the archive; only have a wine32-development-preloader:i386
+ which also fail to install
+ 
  That is: no way to use wine on yakkety 64 bits; these issues are not met
  with xenial 64 bits & the same wine version with a gnome-shell session
  too.
  
  ProblemType: Bug
  DistroRelease: Ubuntu 16.10
  Package: wine-development 1.9.20-1ubuntu1
  ProcVersionSignature: Ubuntu 4.8.0-22.24-generic 4.8.0
  Uname: Linux 4.8.0-22-generic x86_64
  NonfreeKernelModules: nvidia_uvm nvidia_drm nvidia_modeset nvidia
  ApportVersion: 2.20.3-0ubuntu8
  Architecture: amd64
  CurrentDesktop: GNOME
  Date: Wed Oct 12 18:41:12 2016
  PackageArchitecture: all
  SourcePackage: wine-development
  UpgradeStatus: No upgrade log present (probably fresh install)

** Description changed:

  Done a fresh wine-development install on Yakkety 64 bits with a gnome-
  shell session
  
  but:
  - there is no warning/error while doing the wine install (except it remove 
gnome-disk-utility and squasfs-tools which can be reinstalled after without 
problem.)
  - wincfg is not present into the wine menu (from Applications topbar menu)
  - wine-gecko is not installed by default (see warning at this end of report)
  - and get lot of dependencies issues:
  
  oem@u64:~$ wine winecfg
  it looks like wine32-development is missing, you should install it.
  as root, please execute "apt-get install wine32-development"
  wine: created the configuration directory '/home/oem/.wine'
  err:ole:marshal_object couldn't get IPSFactory buffer for interface 
{00000131-0000-0000-c000-000000000046}
  err:ole:marshal_object couldn't get IPSFactory buffer for interface 
{6d5140c1-7436-11ce-8034-00aa006009fa}
  err:ole:StdMarshalImpl_MarshalInterface Failed to create ifstub, 
hres=0x80004002
  err:ole:CoMarshalInterface Failed to marshal the interface 
{6d5140c1-7436-11ce-8034-00aa006009fa}, 80004002
  err:ole:get_local_server_stream Failed: 80004002
  err:ole:marshal_object couldn't get IPSFactory buffer for interface 
{00000131-0000-0000-c000-000000000046}
  err:ole:marshal_object couldn't get IPSFactory buffer for interface 
{6d5140c1-7436-11ce-8034-00aa006009fa}
  err:ole:StdMarshalImpl_MarshalInterface Failed to create ifstub, 
hres=0x80004002
  err:ole:CoMarshalInterface Failed to marshal the interface 
{6d5140c1-7436-11ce-8034-00aa006009fa}, 80004002
  err:ole:get_local_server_stream Failed: 80004002
  Could not load wine-gecko. HTML rendering will be disabled.
  it looks like wine32-development is missing, you should install it.
  as root, please execute "apt-get install wine32-development"
  Could not load wine-gecko. HTML rendering will be disabled.
  wine: configuration in '/home/oem/.wine' has been updated.
  
  oem@u64:~$ sudo apt-get install wine32-development
  [sudo] password for oem:
  Reading package lists... Done
  Building dependency tree
  ...
  
  The following information may help to resolve the situation:
  
  The following packages have unmet dependencies.
   wine32-development:i386 : Depends: libwine-development:i386 (= 
1.9.20-1ubuntu1) but it is not going to be installed
  E: Unable to correct problems, you have held broken packages. # no broken 
package but the wine
  
  oem@u64:~$ sudo apt-get install libwine-development:i386
  ...
  The following information may help to resolve the situation:
  
  The following packages have unmet dependencies.
   libwine-development:i386 : Depends: libldap-2.4-2:i386 (>= 2.4.7) but it is 
not going to be installed
                              Depends: libpulse0:i386 (>= 0.99.1) but it is not 
going to be installed
                              Depends: libxml2:i386 (>= 2.9.0) but it is not 
going to be installed
                              Recommends: libcups2:i386 (>= 1.4.0) but it is 
not going to be installed
                              Recommends: libdbus-1-3:i386 (>= 1.9.14) but it 
is not going to be installed
                              Recommends: libtiff5:i386 (>= 4.0.3) but it is 
not going to be installed
                              Recommends: libxslt1.1:i386 (>= 1.1.25) but it is 
not going to be installed
                              Recommends: libasound2-plugins:i386 but it is not 
going to be installed
  E: Unable to correct problems, you have held broken packages.
  
  note: wine64-development is installed, but the wine32-development is
  missing into the archive; only have a wine32-development-preloader:i386
  which also fail to install
  
+ Could it be a multiarch problem with some dependencies ?
+ 
  That is: no way to use wine on yakkety 64 bits; these issues are not met
  with xenial 64 bits & the same wine version with a gnome-shell session
  too.
  
  ProblemType: Bug
  DistroRelease: Ubuntu 16.10
  Package: wine-development 1.9.20-1ubuntu1
  ProcVersionSignature: Ubuntu 4.8.0-22.24-generic 4.8.0
  Uname: Linux 4.8.0-22-generic x86_64
  NonfreeKernelModules: nvidia_uvm nvidia_drm nvidia_modeset nvidia
  ApportVersion: 2.20.3-0ubuntu8
  Architecture: amd64
  CurrentDesktop: GNOME
  Date: Wed Oct 12 18:41:12 2016
  PackageArchitecture: all
  SourcePackage: wine-development
  UpgradeStatus: No upgrade log present (probably fresh install)

-- 
You received this bug notification because you are a member of Ubuntu
Bugs, which is subscribed to Ubuntu.
https://bugs.launchpad.net/bugs/1632787

Title:
  Can't do a full install on Yakkety 64 bits, nor loading app

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/wine-development/+bug/1632787/+subscriptions

-- 
ubuntu-bugs mailing list
ubuntu-bugs@lists.ubuntu.com
https://lists.ubuntu.com/mailman/listinfo/ubuntu-bugs

Reply via email to