> there is no warning/error while doing the wine install (except it
remove gnome-disk-utility and squasfs-tools which can be reinstalled
after without problem.)

Generallly wine-development tries to install wine32-development, but it
purposedly doesn't fail to install if wine32-development is not
available. Instead running wine-development later shows a hint about
wine32-development and how to install it (as already seen in your

wine32-development is available on your system, as seen in the output.
But maybe some tools don't show it, because it's from the architecture
i386. Nothing to worry about (but see below about it not installing due
to dependency issues).

> wincfg is not present into the wine menu (from Applications topbar

This is unrelated to your main problem.
.desktop files were requested in 

> wine-gecko is not installed by default (see warning at this end of

This is also unrelated. Generally to make Wine Gecko available in Wine someone 
(TM) needs to update either Debian's libwine-geckoX.YZ (suitable for universe) 
or wine-ubuntu's wine-geckoX-YZ (multiverse) to the currently required version 
2.47. For regular users the README.Debian has instructions how to install the 
current version manually, read it e.g. with the following terminal command:
$ zcat /usr/share/doc/wine-development/README.Debian.gz

> and get lot of dependencies issues

So this is your main problem.

Basically you still have the issues that you already reported for other
Wine packages in several other bug reports. On your system apt somehow
refuses to install wine32-development's dependencies from the i386
architecture. This is not a bug in wine-development, or in any of the
other Wine packages.

I know you already added the foreign architecture i386 to your system,
and did the apt update. Good. Others with similar problems should just
follow the instructions they get in the terminal when they run wine-

Possible reasons:

* PPAs or other apt sources, or manually installed .deb packages that
conflict with the to-be-installed i386 packages. I suggest you trim down
this list for now (don't forget to do a "sudo apt update" to apply the
changes) until you've installed wine32-development.

* Some custom setting in /etc/apt/preferences or
/etc/apt/preferences.d/*, or any other apt misconfiguration.

* Your ProcEnviron.txt states: PATH=(custom, no user)
That looks strange to me, but I don't really suspect it to cause the problems.

* something else

I suggest to try to manually install all dependencies, as you already tried 
with libwine-development:i386. Follow down this dependency chain (which might 
be dozens of single packages) until they are all either installed, or you get a 
real package conflict.

apt install libldap-2.4-2:i386

If this works, continue with:
apt install libpulse0:i386

If it fails and complains about new missing dependencies, try them. Also verify 
if the same version from i386 is tried to be installed, as it is already 
installed on amd64 (you don't need to install the amd64 package if it is not 
there yet. But if a package is to be installed from i386 and amd64 at the same 
time (which is the case for most packages here), they need to be of the exact 
same version.). See the currently installed version of e.g. libldap-2.4-2 with 
the following terminal command:
$ dpkg -l libldap-2.4-2

You received this bug notification because you are a member of Ubuntu
Bugs, which is subscribed to Ubuntu.

  Can't do a full install on Yakkety 64 bits, nor loading app

To manage notifications about this bug go to:

ubuntu-bugs mailing list

Reply via email to