** Description changed:

   * 0.122ubuntu8.3 of initramfs-tools no longer correctly processed
  ip=dhcp or ip=:::::eth0:dhcp
   * Regression-updates
   * The fix better parses the ip= command line argument.
  [Test Case]
   * Create a machine that boots using an nfsroot.
   * Use ip=:::::eth0:dhcp on the kernel command line.  To set up
   * Discover that the device never comes up because, networking is not
  configured correctly.
  [Regression Potential]
   * Regressions potential is limited to machines using
  ip={""|::::*|on|any|dhcp} on the kernel command line.  As this is
  already broken regression potential is minimal.  This is common on
  machines that use nfsroot or otherwise pxe boot.
  [Other Info]
-  * There are a number of other issues in this code base that are not solved 
by this fix.
+  * There are a number of other issues in this code base that are not solved 
by this fix. 
+    - The ?*:?*:?*:?*: use case falls through to the default case, and likely 
breaks there.  As such static assignment via ip= appears broken 
+    - 
   * The networking configuration does not strictly follow the kernel 
documentation as described 
https://www.kernel.org/doc/Documentation/filesystems/nfs/nfsroot.txt . This 
should be fixed.
  ====================Original Bug Description Follows==================
  initramfs-tools 0.122ubuntu8.3 introduced a serious regression where
  networking is not initialized when the boot option "ip=dhcp" is
  provided. We are seeing this problem in AWS, but cannot confirm if this
  issue is specific to AWS or will occur with different hardware or in
  different environments.
  Removing "ip=dhcp" from the boot options with 0.122ubuntu8.3 results in
  networking being configured.
  The issue does not occur with 0.122ubuntu8.2 or previous versions when
  "ip=dhcp" is set.
  AWS has no console so debugging is not a trivial task. I do have a
  console log with some output, and will update this bug shortly with it.

You received this bug notification because you are a member of Ubuntu
Bugs, which is subscribed to Ubuntu.

  No networking with initramfs-tools 0.122ubuntu8.3 and ip=dhcp boot

To manage notifications about this bug go to:

ubuntu-bugs mailing list

Reply via email to