Same bug when trying to install my 2 extensions in Firefox 49 on Ubuntu 16.04.1 
: 
- https://addons.mozilla.org/en-US/firefox/addon/rsstodolist/
- https://addons.mozilla.org/en-US/firefox/addon/uniquepasswordbuilder-addon/

Loading extension from debug page works.
Installing extensions on Firefox Developer Edition 
(https://www.mozilla.org/fr/firefox/developer/) works.

Here the console trace when trying to install one of those extension :

************************
A coding exception was thrown in a Promise rejection callback.
See 
https://developer.mozilla.org/Mozilla/JavaScript_code_modules/Promise.jsm/Promise

Full message: TypeError:  is not iterable
Full stack: 
AddonInstall.prototype.onStopRequest/<@resource://gre/modules/addons/XPIProvider.jsm:5974:1
Handler.prototype.process@resource://gre/modules/Promise.jsm -> 
resource://gre/modules/Promise-backend.js:940:21
this.PromiseWalker.walkerLoop@resource://gre/modules/Promise.jsm -> 
resource://gre/modules/Promise-backend.js:816:7
this.PromiseWalker.scheduleWalkerLoop/<@resource://gre/modules/Promise.jsm -> 
resource://gre/modules/Promise-backend.js:750:11

*************************
1476609586196   addons.xpi-utils        WARN    Error: XPI database modified 
after shutdown began (resource://gre/modules/addons/XPIProvider.jsm -> 
resource://gre/modules/addons/XPIProviderUtils.js:458:17) JS Stack trace: 
this.xpidatabase.savechan...@xpiproviderutils.js:458:17 < 
this.xpidatabase.updateactiveadd...@xpiproviderutils.js:1441:9 < 
this.xpiprovider.shutd...@xpiprovider.jsm:2854:7 < 
_startProvider/AMProviderShutdown/<@AddonManager.jsm:802:21 < 
prom...@promise-backend.js:388:5 < 
_startProvider/amprovidershutd...@addonmanager.jsm:800:16 < 
Barrier/this.client.addBlocker/promise</trig...@asyncshutdown.jsm:720:23 < 
Barrier.prototype<._w...@asyncshutdown.jsm:867:7 < 
Barrier.prototype<.w...@asyncshutdown.jsm:851:28 < 
AddonManagerInternal.shutdownManager<@AddonManager.jsm:1199:15

-- 
You received this bug notification because you are a member of Ubuntu
Bugs, which is subscribed to Ubuntu.
https://bugs.launchpad.net/bugs/1628014

Title:
  WebExtension fails to install only on ubuntu packaged firefox

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/firefox/+bug/1628014/+subscriptions

-- 
ubuntu-bugs mailing list
ubuntu-bugs@lists.ubuntu.com
https://lists.ubuntu.com/mailman/listinfo/ubuntu-bugs

Reply via email to