I had the same problem. Updating from 16.04 to 16.10 in place.

I ran boot-repair, but the tool had not been updated during the
migration (the update 16.10 removed the boot-repair ppa from the
sources.list). Running the repair completely botched my grub.cfg files
(update-grub was complaining about syntax errors). After a (painful)
manual restart through the grub command line, I was able to boot.

The I did:
sudo add-apt-repository ppa:yannubuntu/boot-repair
sudo apt-get update
sudo apt-get upgrade

Using the new boot-repair (version 4ppa38, instead of the old 4ppa35), I
ran the repair tool, setup grub again, rebooted, and the "error: no
symbol table. Press any key to continue..." was gone.

People looking for a solution may update boot-repair to 4ppa38, run it,
and see if it fixes it. Make sure to backup your data first, it worked
for me but I can't guarantee that it will work for you.

I am attaching the boot-repair report done with 4ppa35, which may be of
interest for people trying to debug this.

** Attachment added: "boot-repair output"

You received this bug notification because you are a member of Ubuntu
Bugs, which is subscribed to Ubuntu.

  No symbol table. Press any key to continue

To manage notifications about this bug go to:

ubuntu-bugs mailing list

Reply via email to