b) xenial package upgrade tests - PASS
starting with:
$ dpkg -l|grep zstd
ii  libzstd-dev                      0.5.1-1                                    
amd64        fast lossless compression algorithm -- development files
ii  libzstd0                         0.5.1-1                                    
amd64        fast lossless compression algorithm
ii  zstd                             0.5.1-1                                    
amd64        fast lossless compression algorithm -- CLI tool

dist-upgrade:
The following NEW packages will be installed:
  libzstd1
The following packages will be upgraded:
  zstd
1 upgraded, 1 newly installed, 0 to remove and 0 not upgraded.

results in:
ubuntu@xenial-zstd:~$ dpkg -l|grep zstd
ii  libzstd-dev                      0.5.1-1                                    
amd64        fast lossless compression algorithm -- development files
ii  libzstd0                         0.5.1-1                                    
amd64        fast lossless compression algorithm
ii  libzstd1                         1.3.1+dfsg-1~ubuntu0.16.04.1               
amd64        fast lossless compression algorithm
ii  zstd                             1.3.1+dfsg-1~ubuntu0.16.04.1               
amd64        fast lossless compression algorithm -- CLI tool

Installing the new versioned dev package should remove the unversioned one:
ubuntu@xenial-zstd:~$ sudo apt install libzstd1-dev
Reading package lists... Done
Building dependency tree
Reading state information... Done
The following packages will be REMOVED:
  libzstd-dev
The following NEW packages will be installed:
  libzstd1-dev

end result:
ubuntu@xenial-zstd:~$ dpkg -l|grep zstd
ii  libzstd0                         0.5.1-1                                    
amd64        fast lossless compression algorithm
ii  libzstd1                         1.3.1+dfsg-1~ubuntu0.16.04.1               
amd64        fast lossless compression algorithm
ii  libzstd1-dev                     1.3.1+dfsg-1~ubuntu0.16.04.1               
amd64        fast lossless compression algorithm -- development files
ii  zstd                             1.3.1+dfsg-1~ubuntu0.16.04.1               
amd64        fast lossless compression algorithm -- CLI tool

* Conversely, installing the unversioned dev package removes the versioned one:
ubuntu@xenial-zstd:~$ sudo apt install libzstd-dev
Reading package lists... Done
Building dependency tree
Reading state information... Done
The following packages will be REMOVED:
  libzstd1-dev
The following NEW packages will be installed:
  libzstd-dev

* Verify that a simple apt upgrade (not dist-upgrade) upgrades zstd and 
installs the new libzstd1:
Starting with:
ubuntu@xenial-zstd:~$ dpkg -l|grep zstd
ii  libzstd-dev                      0.5.1-1                                    
amd64        fast lossless compression algorithm -- development files
ii  libzstd0                         0.5.1-1                                    
amd64        fast lossless compression algorithm
ii  zstd                             0.5.1-1                                    
amd64        fast lossless compression algorithm -- CLI tool

ubuntu@xenial-zstd:~$ sudo apt upgrade
Reading package lists... Done
Building dependency tree
Reading state information... Done
Calculating upgrade... Done
The following NEW packages will be installed:
  libzstd1
The following packages will be upgraded:
  zstd

correctly results in:
ubuntu@xenial-zstd:~$ dpkg -l|grep zstd
ii  libzstd-dev                      0.5.1-1                                    
amd64        fast lossless compression algorithm -- development files
ii  libzstd0                         0.5.1-1                                    
amd64        fast lossless compression algorithm
ii  libzstd1                         1.3.1+dfsg-1~ubuntu0.16.04.1               
amd64        fast lossless compression algorithm
ii  zstd                             1.3.1+dfsg-1~ubuntu0.16.04.1               
amd64        fast lossless compression algorithm -- CLI tool

-- 
You received this bug notification because you are a member of Ubuntu
Bugs, which is subscribed to Ubuntu.
https://bugs.launchpad.net/bugs/1717040

Title:
  Please backport libzstd 1.3.1+dfsg-1 (universe) from artful

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/libzstd/+bug/1717040/+subscriptions

-- 
ubuntu-bugs mailing list
ubuntu-bugs@lists.ubuntu.com
https://lists.ubuntu.com/mailman/listinfo/ubuntu-bugs

Reply via email to