Thanks for filing this bug in Ubuntu.

The logs show:
Setting up ntp (1:4.2.8p10+dfsg-5ubuntu3.2) ...
Installing new version of config file /etc/apparmor.d/usr.sbin.ntpd ...
Segmentation fault (core dumped)
dpkg: error processing package ntp (--configure):
 subprocess installed post-installation script returned error exit status 139

And in dmesg:
[721832.927616] addgroup[1326]: segfault at 339 ip 00005569dd6ce6f6 sp 
00007ffd260fb1f0 error 4 in perl[5569dd5bb000+1f7000]

The ntp postinst always calls addgroup and adduser:
if [ "$1" = "configure" ]; then
    addgroup --system --quiet ntp
    adduser --system --quiet --ingroup ntp --no-create-home --home /nonexistent 
ntp
...

Can you check if you already have an ntp user and group please:

id ntp
getent group ntp
getent passwd ntp


And try one more time:
sudo apt update
sudo apt -f install

Please post back the results. Thanks!


** Changed in: ntp (Ubuntu)
       Status: New => Incomplete

-- 
You received this bug notification because you are a member of Ubuntu
Bugs, which is subscribed to Ubuntu.
https://bugs.launchpad.net/bugs/1753059

Title:
  package ntp 1:4.2.8p10+dfsg-5ubuntu3.2 failed to install/upgrade:
  subprocess installed post-installation script returned error exit
  status 139

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/ntp/+bug/1753059/+subscriptions

-- 
ubuntu-bugs mailing list
ubuntu-bugs@lists.ubuntu.com
https://lists.ubuntu.com/mailman/listinfo/ubuntu-bugs

Reply via email to