Public bug reported:

We discovered a bug [1] that is present in all version of Blosc from
1.11.0 to 1.13.5 (inclusive). The bug prevents data compressed with
these versions using the LZ4, LZ4HC, Zlib and Zstd compressors from
being decompressed using any prior versions of Blosc (it's an accidental
forward-compatiblity break). So in a sense, these versions should be
considered bad apples.

The bug was subsequently fixed [2] and the fix is present in the now
released 1.14.0. The upstream author also blogged [3] about this

I alerted the Debian package maintainer (Daniel Stender) about this [4],
and he was kind enough to quickly package the bugfixed version [5].

I therefore ask you to please sync this bugfixed version to bionic,
since it would be unfortunate if it was released with one of the "bad"

Many thanks in advance!


** Affects: c-blosc (Ubuntu)
     Importance: Undecided
         Status: New

You received this bug notification because you are a member of Ubuntu
Bugs, which is subscribed to Ubuntu.

  Please sync c-blosc 1.14.0+ds1-1 from debian unstable to bionic
  (1.11.1 has format incompat bug!)

To manage notifications about this bug go to:

ubuntu-bugs mailing list

Reply via email to