Public bug reported:

I am currently running Kubuntu 18.04 Bionic Beaver with a GTX 1060 6gb.
I installed the latest version of nvidia-graphics-drivers-390 and signed
the modules using the following command:

sudo /usr/src/linux-headers-4.15.0-13-generic/scripts/sign-file sha256
~/.ssl/MOK.priv ~/.ssl/MOK.der {nvidia_dkms_module}.ko

This step was necessary to enable secureboot with a signed kernel on
18.04. This is required with mokutil. This process has worked without a
hitch since 360 or so. Unfortunately, when I now boot, sddm refuses to
load and when I run systemctl, the gpu-manager.service and sddm.service

I tried with the command startX and manipulating/removing xorg.conf with
little success.

I am now trying just to load the kernel modules using modprobe nvidia
and I am getting the following error.

"module: x86/modules: Skipping invalid relocation target, existing value
is nonzero for type 1, loc <Random location> val ffffffffc21c04c0

modprobe: Error: could not insert 'nvidia': Exec format error."

This is when installing nvidia-graphics-drivers-390=390.48-0ubuntu2.

Could I perhaps have some clarity over this issue? From reading online,
it seems that the kernel modules weren't built for 4.15.0-13. I have
tried installing nvidia 390.48-0ubuntu1+gpu18.04.1 from the graphics-
drivers ppa but that also had similar issues.

** Affects: nvidia-graphics-drivers-390 (Ubuntu)
     Importance: Undecided
         Status: New

You received this bug notification because you are a member of Ubuntu
Bugs, which is subscribed to Ubuntu.

  Nvidia invalid relocation target when performing 'modprobe nvidia' on

To manage notifications about this bug go to:

ubuntu-bugs mailing list

Reply via email to