On 2/16/23 05:07, Hendrik Zumfeld wrote:
Hey there,

today i have updated my T560 laptop to Ubuntu 22.04. After that it was completely broken. When starting only a white screen appears with hieroglyphs. When calling the grub loader i was able to select the kernel and i figured out that with my Ubuntu 22.04.1 upgrade, the command "do-release-upgrade" have installed the kernel 5.19 instead of 5.15 (or both).

When starting the laptop with 5.15 everything works fine, with 5.19 everything was broken. Wlan has not worked, booting has not worked, nearly nothing has worked. I was about to reinstall everything.

I googled and i found the information that 5.19 should be installed with 22.04.2 and not with 22.04.1. So i guess something went wrong on your site.

LTS releases of Ubuntu automatically "upgrade" from point release to point release without needing a do-release-upgrade, so 22.04 goes to 22.04.1 to 22.04.2 without an upgrade - this is because each point release is really just a convenience to make future installs have more updates pre-installed. (And helps with bug fixes.) Kernel 5.19 has rolled out to the 22.04 release, so it's expected that it will be installed if you upgrade to 22.04. If you install 22.04.1, and then upgrade, you will likely end up with kernel 5.19. And you'll end up with kernel 5.19 if you install 22.04.2 once it is released.

But it shouldn't break your system, that seems bad. A white screen with hieroglyphs almost sounds like maybe your initramfs files didn't generate right somehow?

To begin with, I'd highly recommend making backups of your data before proceeding with any fix attempts, so that if anything goes awry you can recover.

Once you have backups, can you run the following commands while booted into kernel 5.15:

dpkg-query -s linux-image-5.19.0-32-generic

dpkg-query -s linux-headers-5.19.0-32-generic

dpkg-query -s linux-modules-5.19.0-32-generic

dpkg-query -s linux-modules-extra-5.19.0-32-generic

If any of those packages show as "not installed", run "sudo apt install linux-image-generic-hwe-22.04" and that should install the kernel fully. Also run "sudo apt install linux-generic" to make good and sure that a 5.15 kernel sticks around on your system for recovery purposes. Finally, also run "sudo update-initramfs -c -k all" to make sure the initramfs files are properly generated for all installed kernels.

Once that's done, try booting into 5.19 again and see if you still get the same results. If so, your hardware might be incompatible with kernel 5.19, or perhaps there's a different problem on your machine.

Sorry to hear that an upgrade went south on you - hopefully we can debug it and get your system back up-and-running normally.

Also, if you can reply to the ubuntu-users list only since this is for support currently, that would be ideal. (You posted to the right list for reporting a problem, I'm just asking for us to move to the other one for now since this looks like it may not be a problem with Ubuntu itself, but rather with your system.)

I hope my report can help you.

Many greetings

Aaron Rainbolt
Lubuntu Developer
@arraybolt3:lubuntu.me on Matrix, arraybolt3 on irc.libera.chat

Attachment: OpenPGP_0x6169B9B4248C0464.asc
Description: OpenPGP public key

Attachment: OpenPGP_signature
Description: OpenPGP digital signature

Ubuntu-devel-discuss mailing list
Modify settings or unsubscribe at: 

Reply via email to