Brian Milby wrote:

> Htmltext of a field is not the same as htmltext of the browser widget.

One of the best ideas Mark Waddingham ever had that he later abandoned was about ten years ago when he proposed adding "xmlText" as a synonym for "htmlText", flagging "htmlText" for eventual deprecation.

The best idea he never expressed having was calling the browser widget property "html" rather than "htmlText". Because that's what it is.

HTML is not htmlText.

Using that name for the field property hints at field capabilities that don't exist.

And then using that same name for the VERY different data in the browser object only makes a bad name worse.

I can understand why "htmlText" was used in the mid-90s when it was introduced, but it wasn't really a solid fit even then, and has become ever less like HTML every year since, causing ever more confusion.


 Richard Gaskin
 Fourth World Systems
 Software Design and Development for the Desktop, Mobile, and the Web

use-livecode mailing list
Please visit this url to subscribe, unsubscribe and manage your subscription 

Reply via email to