I would not do it that way. To make it more readable I would use:

put the customProperties["Prefs"] of stack "Prefs" into tPrefs
put "binfile:"& specialFolderPath("Preferences") & "/MyPrefs.dat" into tFilePath
put arrayEncode(tPrefs) into url tFilePath

That is english readable as much as can be expected. I think that trying to 
make the code compact is counter to making the code readable.

MHO
Bob S

On Apr 19, 2017, at 09:58 , Richard Gaskin via use-livecode 
<use-livecode@lists.runrev.com<mailto:use-livecode@lists.runrev.com>> wrote:

E.g. this:

 put arrayEncode( the customProperties["Prefs"] of stack "Prefs" ) \
    into url ("binfile:"& specialFolderPath("Preferences") & \
    "/MyPrefs.dat" )

...is readable enough, but far from English.

_______________________________________________
use-livecode mailing list
use-livecode@lists.runrev.com
Please visit this url to subscribe, unsubscribe and manage your subscription 
preferences:
http://lists.runrev.com/mailman/listinfo/use-livecode

Reply via email to