for me "Picture" is a bit confusing.

We have "Image" for bitmaps, "Graphic" for vector graphics of a certain type 
and now we might have "Picture" for all kinds of elements.

However "Picture" is easily confused with "Image" or "Graphic" for a newcomer. 
The forum is full of synonyms that take a graphic for a bitmap and an image for 
a vector graphic.

Why not call the new widget something like "Blackboard"? Or something like 
that. It conveys the notion that you can put all sort of things onto a 
blackboard, regardless of their internal representation. It alludes to the 
container for those things not the result of what is displayed.

I like "Canvas" from LCB but unfortunately that is already taken. It would have 
been my favorite.

Logically "Image", "Graphic" and "Picture" are all elements of a class of 
"visuals", but now "Image" and "Graphic" become elements of the class 

It is a bit fuzzy what the difference in logical hierarchy is. A new term could 
prevent a possible confusion that "Picture" is a new logical class with said 
elements but at the same time a picture could be considered a member of class 

Kind regards
use-livecode mailing list
Please visit this url to subscribe, unsubscribe and manage your subscription 

Reply via email to