1.2 TB 15K

latency reported by stress tool is 7.6 ms. disk latency is 2.6 ms


Sent using Zoho Mail






---- On Mon, 12 Mar 2018 14:02:29 +0330 Jacques-Henri Berthemet 
<jacques-henri.berthe...@genesys.com> wrote ----




What’s your disk latency? What kind of disk is it?

 

--

Jacques-Henri Berthemet


 

From: onmstester onmstester [mailto:onmstes...@zoho.com] 

 Sent: Monday, March 12, 2018 10:48 AM

 To: user <user@cassandra.apache.org>

 Subject: Re: yet another benchmark bottleneck




 

Running two instance of Apache Cassandra on same server, each having their own 
commit log disk dis not help. Sum of cpu/ram usage  for both instances would be 
less than half of all available resources. disk usage is less than 20% and 
network is still less than 300Mb in Rx.


 


Sent using  Zoho Mail


 


 


---- On Mon, 12 Mar 2018 09:34:26 +0330 onmstester onmstester 
<onmstes...@zoho.com> wrote ----



 


Apache-cassandra-3.11.1


Yes, i'm dosing a single host test


 


Sent using  Zoho Mail


 


 


---- On Mon, 12 Mar 2018 09:24:04 +0330 Jeff Jirsa <jji...@gmail.com> 
wrote ----



 


 



 




Would help to know your version. 130 ops/second sounds like a ridiculously low 
rate. Are you doing a single host test? 


 


On Sun, Mar 11, 2018 at 10:44 PM, onmstester onmstester 
<onmstes...@zoho.com> wrote:


 





 


I'm going to benchmark Cassandra's write throughput on a node with following 
spec:


CPU: 20 Cores

Memory: 128 GB (32 GB as Cassandra heap)

Disk: 3 seprate disk for OS, data and commitlog

Network: 10 Gb (test it with iperf)

Os: Ubuntu 16

 


Running Cassandra-stress:


cassandra-stress write n=1000000 -rate threads=1000 -mode native cql3 -node 
X.X.X.X


 


from two node with same spec as above, i can not get throughput more than 130 
Op/s. The clients are using less than 50% of CPU, Cassandra node uses:


60% of cpu

30% of memory

30-40% util in iostat of commitlog

300 Mb of network bandwidth

I suspect the network, cause no matter how many clients i run, cassandra always 
using less than 300 Mb. I've done all the tuning mentioned by datastax.


Increasing wmem_max and rmem_max did not help either.


 


Sent using  Zoho Mail


 





 



 





Reply via email to