Try that:
groovy -cp C:\DevCenter\plugins\*.jar Cass1.groovy 

Jacques-Henri Berthemet

-----Original Message-----
From: phi...@free.fr [mailto:phi...@free.fr] 
Sent: Tuesday, March 13, 2018 9:40 AM
To: user@cassandra.apache.org
Subject: Re: Cassandra DevCenter

Good morning,

when I run 

groovy -cp .\cassandra-driver-core-3.4.0.jar;C:\DevCenter\plugins Cass1.groovy 

I get the following error message:

"groovy vopts = "
Caught: java.lang.NoClassDefFoundError: 
java.lang.NoClassDefFoundError: com/google/common/util/concurrent/AsyncFunction
        at Cass1.retrieveCities(Cass1.groovy:25)
        at Cass1.run(Cass1.groovy:67)
Caused by: java.lang.ClassNotFoundException: 
        ... 2 more

Here's my Groovy code:


import com.datastax.driver.core.Cluster
import com.datastax.driver.core.Host
import com.datastax.driver.core.Metadata import 
com.datastax.driver.core.Session import com.datastax.driver.core.ResultSet
import com.datastax.driver.core.Row
import com.datastax.driver.core.ProtocolOptions.Compression
import java.sql.SQLException

def retrieveCities() {
        final def hostsIp = 'xxx,bbb,ccc'
        final def hosts = '....'
        def Cluster cluster = 
Cluster.builder().addContactPoints(hostsIp.split(','))  <== line 25
                // com.datastax.driver.core.ProtocolOptions.Compression.LZ4
                .withCredentials( '...' , '...')


As a reminder, I can't download missing dependencies as I have no access to 

As a result, I must rely only on the cassandra-driver-core-3.4.0.jar jar and/or 
the DevCenter jars.

Any help would be much appreciated.


----- Mail original -----
De: "Jacques-Henri Berthemet" <jacques-henri.berthe...@genesys.com>
À: user@cassandra.apache.org
Envoyé: Lundi 12 Mars 2018 09:44:27
Objet: RE: Cassandra DevCenter


There is no DevCenter 2.x, latest is 1.6. It would help if you provide jar 
names and exceptions you encounter. Make sure you ’ re not mixing Guava 
versions from other dependencies. DevCenter uses Datastax driver to connect to 
Cassandra, double check the versions of the jars you need here: 


Put only the jars listed on the driver version you have on you classpath and it 
should work. 


Jacques-Henri Berthemet 

From: Philippe de Rochambeau [mailto:phi...@free.fr]
Sent: Saturday, March 10, 2018 6:56 PM
To: user@cassandra.apache.org
Subject: Re: Cassandra DevCenter 


thank you for replying. 

Unfortunately, the computer DevCenter is running on doesn’t have Internet 
access (for security reasons). As a result, I can’t use the pom.xml. 

Furthermore, I’ve tried running a Groovy program whose classpath included the 
DevCenter (2.x) lib directory, but to no avail as a Google dependency was 
missing (I can’t recall the dependency’s name). 

Because DevCenter manages to connect to Cassandra without downloading 
dependencies, there’s bound to be a way to drive the former using Java or 

Le 10 mars 2018 à 18:34, Goutham reddy < goutham.chiru...@gmail.com > a écrit : 

Get the JARS from Cassandra lib folder and put it in your build path. Or else 
use Pom.xml maven project to directly download from repository. 

Thanks and Regards, 

Goutham Reddy Aenugu. 

On Sat, Mar 10, 2018 at 9:30 AM Philippe de Rochambeau < phi...@free.fr > 

has anyone tried running CQL queries from a Java program using the jars 
provided with DevCenter? 
Many thanks. 

To unsubscribe, e-mail: user-unsubscr...@cassandra.apache.org
For additional commands, e-mail: user-h...@cassandra.apache.org 



Goutham Reddy

To unsubscribe, e-mail: user-unsubscr...@cassandra.apache.org
For additional commands, e-mail: user-h...@cassandra.apache.org

Reply via email to