When I first used the clinical pipeline I did so through the Collection
Processing Engine Configuration. In the last step results are written to
XML (I think this is the default CAS Consumer). As a next step I wanted to
start experimenting with a clinical pipeline so I decided to first create
a pipeline with the cTAKES Simple Pipeline Fabrication. This is my

package org.apache.ctakes.core.cr
readFiles C:\Reports
add SimpleSegmentAnnotator
add SentenceDetector
add TokenizerAnnotatorPTB
add ContextDependentTokenizerAnnotator
addDescription POSTagger
add Chunker
addDescription adjuster.ChunkAdjuster NP,NP 1
addDescription adjuster.ChunkAdjuster NP,PP,NP 2
add DefaultJCasTermAnnotator
addDescription ClearNLPDependencyParserAE
addLogged ClearNLPSemanticRoleLabelerAE
package org.apache.ctakes.assertion.medfacts.cleartk
addDescription PolarityCleartkAnalysisEngine
addDescription UncertaintyCleartkAnalysisEngine
addDescription HistoryCleartkAnalysisEngine
addDescription ConditionalCleartkAnalysisEngine
addDescription GenericCleartkAnalysisEngine
addDescription SubjectCleartkAnalysisEngine
add org.apache.ctakes.core.cc.XmiWriterCasConsumerCtakes

This pipeline works when I run it from the command line (bin\runPiperFile
-p "C:\clinicalPipeline2.piper" --user XXXXX --pass "XXXXXX" (with my
actual umls username and pw)). However, it generates XMI output and since
I was using code to parse the XML files I created before I wanted to
create XML output instead. I therefore changed the last line in the above
piper script to:

add org.apache.ctakes.core.cc.CasConsumer outputDir=C:\cTakesOutput

When I run the pipeline now I get the following error:

ERROR PiperFileRunner - MESSAGE LOCALIZATION FAILED: Can't find resource
for bundle java.util.PropertyResourceBundle, key Not AnalysisComponent

I must be doing something wrong here but I haven't been able to figure out
what. Maybe it is trivial but I am new to cTakes so any suggestions are
welcome. I am using cTakes 4.0.0.

Thank you,


Reply via email to