Hi Michael,

can you provide a patch or pull request for the upgrade?

There is an issue open since long [1] but the available
patches are reported to raise further issues (see issue comments).
The challenge is indeed to to test all the authentication options
supported by protocol-httpclient including form authentication.

Cheers,
Sebastian

[1] https://issues.apache.org/jira/browse/NUTCH-1086

On 4/26/19 4:50 PM, Michael Portnoy wrote:
> Nutch 1.14 is using HttpClient 3.x which does not work with NTLM2. Not sure
> if that's your case. To get auth to work, we've had to migrate the
> httpclient plugin to use HttpClient 4.x
> 
> This may have been done in Nutch 1.15
> 
> On Fri., Apr. 26, 2019, 10:24 a.m. Larry.Santello, <larry.sante...@uline.com>
> wrote:
> 
>> Been reading a bit more and it sounds like an option may be to use an ntlm
>> proxy. You have Nutch set up for the proxy, and it's the proxy that sends
>> ntlm credentials. Ntlmaps seems like the product of choice for that proxy.
>> I
>> guess I'll give that a shot on Monday.
>>
>>
>>
>> --
>> Sent from: http://lucene.472066.n3.nabble.com/Nutch-User-f603147.html
>>
> 

Reply via email to