We had to extend the SimpleTransportPlugin to override the default
framesize limit.

Does anyone know of any other cleaner solution available ?

PlainSaslTransportPlugin was introduced as its replacement but it doesn't
seem to work.

Thanks and Regards,

On Sep 15, 2016 8:17 PM, "Devang Shah" <devangsha...@gmail.com> wrote:

> Hello Storm group,
> We are in process of migrating from storm 0.9.3 to 1.0.1 but are facing an
> issue with DRPC where we see an exception of "frame size greater than 16MB"
> while processing DRPC request. We have NOT changed the default
> SimpleTransportPlugin.
> Solutions tried so far,
> 1. Updated the nimbus and DRPC max_buffer_size in storm.yaml to a value
> greater than 16 MB. But the plug-in still picks up 16MB harcoded size.
> 2. SimpleTransportPlugin seems to be deprecated so tried using
> PlainSaslTransportPlugin but that fails with  "Invalid status: 0" exception.
> Has anyone encountered similar issue with DRPC Storm 1.0.1 ?
> Regards,
> Dev

Reply via email to