旧的pid可在/var/run/下面找到并删除. 但这个不一定能解决你的问题, 不建议在已经添加到资源域过的机器上再次重新添加到另一个资源域. 这样太多垃圾信息. 你在KVM上brctl show看一下bridge信息有哪些, ifconfig -a 输出是什么, 估计要清一下网络设置. 同样的, CloudStack端也有些信息要清理.
2013/4/2 niz <[email protected]> > ** > 我删掉了之前建的高级网络,重新创建了一个zone,但是在添加KVM主机时遇到错误: > > 2013-04-02 10:13:26,106 ERROR [cloud.agent.AgentShell] (main:null) Unable to > start agent: > > com.cloud.utils.exception.CloudRuntimeException: Failed to connect socket to > '/var/run/libvirt/libvirt-sock': Connection refused; > > 一直没有找到解决办法,于是重启主机后, > 查看libvirt服务状态:[root@kvm150 > CloudStack-oss-3.0.2-1-rhel6.2]# service libvirtd status > libvirtd dead but pid file exists > 用yum重装libvirt之后还是出现同样的问题。 > hypervisor主机用的是centos6.2的系统。 > > 请问这个问题如何解决?如何删除这个旧的pid?或者如何使主机能够正确添加上? > 2013-04-02 > ------------------------------ > > 倪珍 综合管理部**** > > 网宿科技股份有限公司 厦门分公司 **** > > [image: 说明: 说明: 说明: > C:\Users\zhuangwm\AppData\Local\Microsoft\Windows\Temporary Internet > Files\line1(09-10-15-05-51).jpg]**** > > Tel: 0592-5520608-8022 > Fax:0592-5520515 > E-mail:[email protected] > http://www.chinanetcenter.com**** > > [image: 说明: 说明: LOGO small]**** > > 分公司:北京-上海-广州-深圳 > 免费咨询:800-816-8777 > 卓越的互联网业务平台提供商**** > > [image: 说明: 说明: 说明: > C:\Users\zhuangwm\AppData\Local\Microsoft\Windows\Temporary Internet > Files\line2(09-10-15-05-51).jpg]**** > > ** ** > > ** ** > -- Gavin
