On 04/20/2017 10:30 AM, Klechomir wrote:
> Hi List,
> Been investigating the following problem recently:
>
> Have two node cluster with 4 cloned (2 on top of 2) + 1 master/slave services 
> on it (corosync+pacemaker 1.1.15)
> The failover works properly for both nodes, i.e. when one node is 
> restarted/turned in standby, the other properly takes over, but:
>
> Every time when node2 has been in standby/turned off and comes back, 
> everything 
> recovers propery.
> Every time when node1 has been in standby/turned off and comes back, part of 
> the cloned services on node2 are getting instantly restarted, at the same 
> second when node1 re-appeares, without any apparent reason (only the 
> stop/start messages in the debug).
>
> Is there some known possible reason for this?

That triggers some deja-vu feeling...
Did you have a similar issue a couple of weeks ago?
I remember in that particular case 'interleave=true' was not the
solution to the problem but maybe here ...

Regards,
Klaus

>
> Best regards,
> Klecho
>
> _______________________________________________
> Users mailing list: Users@clusterlabs.org
> http://lists.clusterlabs.org/mailman/listinfo/users
>
> Project Home: http://www.clusterlabs.org
> Getting started: http://www.clusterlabs.org/doc/Cluster_from_Scratch.pdf
> Bugs: http://bugs.clusterlabs.org


-- 
Klaus Wenninger

Senior Software Engineer, EMEA ENG Openstack Infrastructure

Red Hat

kwenn...@redhat.com   


_______________________________________________
Users mailing list: Users@clusterlabs.org
http://lists.clusterlabs.org/mailman/listinfo/users

Project Home: http://www.clusterlabs.org
Getting started: http://www.clusterlabs.org/doc/Cluster_from_Scratch.pdf
Bugs: http://bugs.clusterlabs.org

Reply via email to