Erik,

FWIW we're not a "serious software development company", we're a shipping 
company.  I suspect most here are dealing with Flex as a legacy solution.  I'm 
certain that using legacy tooling in order to support legacy software isn't 
rare.  I'm also certain that it's foolish to comment on the quality of a 
business decision without having the slightest insight into that particular 
business.  To say that we have solutions (and dev tools) spanning decades would 
be an understatement.  We have software that runs on mainframes and we have 
other software that runs on nearly all modern mobile devices.

-Jeff
________________________________
From: Erik J. Thomas <e...@linqto.com>
Sent: Tuesday, April 10, 2018 11:35 AM
To: users@flex.apache.org
Subject: Re: Flex Installer - Air 29 - OSMF Fail (Windows)

I continue to be amazed that any serious software development company would 
choose to use a development IDE that was released in 2011 and has not been 
updated since 4.7 in 2012. It's a poor business decision, plain and simple, 
IMHO.

A few years ago, after extensive research and frustration with FlashBuilder, 
our team switched to IntelliJ IDEA. We have never looked back.

Sure it's not free, but neither was FlashBuilder, and saving $200/yr per person 
to work with crap tools just doesn't make any business sense.

Take the plunge, it will take your developers a few days, maybe a week to be up 
to full velocity again, but that cost will be recouped in a month or two as 
your overall development velocity will improve with so many modern tools packed 
into IntelliJ. Upgrading AIR/Flex SDKs is also a breeze in comparison.

I have no stake in JetBrains, and have no reason to endorse their product 
except that it rocks, as does their support. But if you choose to stay with 
FlashBuilder, be sure to never upgrade your iPhone 4 or Blackberry. LOL

Erik

On Apr 9, 2018, at 10:09 AM, Carlos Rovira <carlosrov...@apache.org> wrote:

Hi Jeff,

for IDEs, if a part from flex you have backend code (maybe Java?) my
recommendation is to switch to IntelliJ IDEA since the Java/Flex support is
very professional. We switched many years ago from Flash Builder since it
supports as well maven with flex. I think it was a great decision since we
have a huge  code base like you.

For Royale, you can go as well IntelliJ (but there's no official support,
just what Flex support gives you a long some hacks people do).
For Royale, better to go with Moonlight or VSCode + Extension (NextGenAS).

Best,

Carlos



2018-04-09 18:46 GMT+02:00 Jeff Dafoe <jeffda...@gmail.com>:

> Hi Piotr,
>
> I didn't mean to direct any ire to the team, I do know it's volunteer-only
> and believe me, I appreciate your offer to look at the installer.  I'm also
> very thankful for the work that the open source community has done to help
> the Flex SDK stay alive.  I'm also watching the Royale project advances and
> it's impressive.  My mood was more directed at Adobe (who isn't even here,
> so that was pointless of me) concerning the deactivation of all Flash
> Builder 4.6 licenses.
>
> I guess a more productive thing for me to ask is what development tooling
> is used aside from Flash Builder?  I understand you can edit the source
> with any text editor and build via command-line, is that what most people
> do these days?  We've always used FB and the integrated build and debug.
> I've seen a couple of IDEs here and there but I haven't really been able to
> tell if any tool or process has become standardized.  We're entirely on
> Windows (for dev) here.
>
> Thank you,
> -Jeff
> ________________________________
> From: Piotr Zarzycki <piotrzarzyck...@gmail.com>
> Sent: Monday, April 9, 2018 11:53 AM
> To: users@flex.apache.org
> Subject: Re: Flex Installer - Air 29 - OSMF Fail (Windows)
>
> Hi Jeff,
>
> We are all volunteers, so fixing things does require some time. I'm working
> on that and hope to find out some solution. If not I will probably post
> some finding on Development list. Will see what happen after brainstorming.
>
> Thanks for the input,
> Piotr
>
> 2018-04-09 17:38 GMT+02:00 Jeff Dafoe <jeffda...@gmail.com>:
>
>>
>> At my organization, we've used Flex for probably 10 years now and we have
>> what I think may be one of the largest Flex codebases (over 200k lines of
>> source).  We went to onboard a new developer last week and it was quite a
>> disappointment for me.  Flex Builder 4.6 will no longer install, Adobe
> has
>> turned off the license servers so you have to route them to 127.0.0.1 in
>> your hosts file (which our admins, also in charge of software licensing,
>> were not thrilled with).  This issue took us 3 days to troubleshoot
> before
>> we finally came across the thread in the Adobe forum (one of our
> sysadmins
>> is the guy who posted the hosts file solution, they were using the Win
>> firewall prior to that but that's not an option for us).  Then the SDK
>> installer fails on the OSMF installation.  It was very disheartening and
>> really didn't impress the new dev.
>>
>> -Jeff
>> ________________________________
>> From: Lydecker <z...@zizunetwork.co.uk>
>> Sent: Wednesday, March 21, 2018 8:01 AM
>> To: users@flex.apache.org
>> Subject: Flex Installer - Air 29 - OSMF Fail (Windows)
>>
>> Hi - I'm trying to use the latest SDK installer to install Flex/Air29 on
>> WINDOWS.
>>
>> The installer downloads the Flex SDK and Air SDK and unpacks them, but
> then
>> fails when it gets to the OSMF download.
>>
>> Any ideas?
>>
>> Log below:
>>
>>
>> Installer version 3.3.0 (windows)
>> Using Locale: en_GB
>> Fetched the SDK download mirror URL from the CGI.
>> SDK version Apache Flex SDK 4.16.1
>> AIR version 29.0
>> Flash Player version 29.0
>> Creating Apache Flex home
>> Creating temporary directory
>> Downloading Apache Flex SDK from:
>> http://apache.mirror.anlx.net/flex/4.16.1/binaries/apache-
>> flex-sdk-4.16.1-bin.zip
>> Verifying Apache Flex SDK MD5 Signature
>> The Apache Flex SDK MD5 Signature of the downloaded files matches the
>> reference. The file is valid.
>> Unzipping: C:\Users\z\Desktop\f29\temp\apache-flex-sdk-4.16.1-bin.zip
>> Finished unzipping:
>> C:\Users\z\Desktop\f29\temp\apache-flex-sdk-4.16.1-bin.zip
>> Downloading Adobe AIR Runtime Kit for Windows from:
>> http://airdownload.adobe.com/air/win/download/29.0//AdobeAIRSDK.zip
>> Validating download: C:\Users\z\Desktop\f29/in/AdobeAIRSDK.zip
>> Finished unzipping: C:\Users\z\Desktop\f29/in/AdobeAIRSDK.zip
>> Installing Adobe Flash Player playerglobal.swc from:
>> http://fpdownload.macromedia.com/get/flashplayer/updaters/
>> 29//playerglobal29_0.swc
>> Validating download:
>> C:\Users\z\Desktop\f29/frameworks/libs/player/29.0/playerglobal.swc
>> Downloading 2.2.zip from: https://github.com/swfobject/swfobject/archive
>> Validating download: C:\Users\z\Desktop\f29/in/swfobject_2_2.zip
>> Download complete
>> Downloading OSMF2_0.swc?format=raw from:
>> http://sourceforge.net/adobe/flexsdk/code/HEAD/tree/trunk/
> frameworks/libs
>> Validating download: C:\Users\z\Desktop\f29/frameworks/libs/osmf.swc
>> OSMF download failed
>> Aborting Installation:
>> http://flex.apache.org/track-installer.html?failure=true&label=Apache
> Flex
>> SDK
>> 4.16.1&version=4.16.1&os=windows&installerversion=3.3.
>> 0&info=&info=OSMF%20download%20failed
>>
>>
>>
>>
>> --
>> Sent from: http://apache-flex-users.2333346.n4.nabble.com/
>>
>
>
>
> --
>
> Piotr Zarzycki
>
> Patreon: *https://www.patreon.com/piotrzarzycki
> <https://www.patreon.com/piotrzarzycki>*
>



--
Carlos Rovira
http://about.me/carlosrovira

Reply via email to