I've updated the httpd 2.2.x doc in revision r1772232 to suggest a minimum APR of 1.4.

On 12/1/2016 7:29 AM, Mike Rumph wrote:
Hello Noor,

httpd 2.2.31 should have been bundled with APR 1.5.2
To force the use of the bundled apr/apr-util add --with-included-apr to your ./configure step.
- http://httpd.apache.org/docs/2.2/install.html#requirements

Hello Nick,

I notice that the doc I just referenced is not up to date.
It says that a minimum of APR 1.2 is required.
But the fix that adds apr_sockaddr_ip_getbuf to network_io/unix/sockaddr.c is not in the 1.2.x branch.
This was added to trunk in revision 279566.
The fix is in the APR 1.4.x branch.
So the doc should be changed to suggest a minimum APR of 1.4

Thanks,

Mike

On 12/1/2016 6:32 AM, Nick Kew wrote:
On Thu, 1 Dec 2016 18:18:26 +0530
noor mahammad <mahammad4n...@gmail.com> wrote:

Hi,
the apr version is '1.2.7-11.el5_6.5'.
So that's an installed package.

the command using for compiling the apache is
So you've mixed a packaged APR, which is ancient and
might also be non-standard, with a self-built httpd.
Most likely fix is to upgrade APR and APR-UTIL.
Or use the ones bundled in the httpd package.

cd httpd-2.2.31
./configure --prefix=/nfs/apache_120/apache --with-mpm=worker
You might want to add an explicit --with-apr (and apr-util)
to that.



---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscr...@httpd.apache.org
For additional commands, e-mail: users-h...@httpd.apache.org




---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscr...@httpd.apache.org
For additional commands, e-mail: users-h...@httpd.apache.org

Reply via email to