Hi,

Le 09/04/2018 à 17:29, Kevin Klein a écrit :
> […]
> 
> setenv PKG_CONFIG_PATH /user/kklein/geany/1.33/lib/pkgconfig____
> 
> setenv GLIB_CFLAGS -I/usr/include/glib-2.0____

Why are you setting GLIB_CFLAGS?  You shouldn't do that manually but on
*very* specific cases.  Normally it should discover the appropriate
flags through the pkg-config system, and those should be correct.

> ./configure --prefix=/user/kklein/geany/1.33
> --exec-prefix=/user/kklein/geany/1.33
> --with-geany-libdir=/user/kklein/geany/1.33/lib____

You shouldn't have to specify --exec-prefix manually if it matches
`--prefix`, and you shouldn't have to specify --with-geany-libdir if the
Geany package is properly found via pkg-config.

> The configure step produces the following header file errors, but
> nothing related to glib.h:
> 
> 
> conftest.c:11:28: fatal error: ac_nonexistent.h: No such file or directory
> 
> conftest.c:26:42: fatal error: CoreFoundation/CFPreferences.h: No such
> file or directory
> 
> conftest.c:26:37: fatal error: CoreFoundation/CFLocale.h: No such file
> or directory
> 
> conftest.c:63:18: fatal error: util.h: No such file or directory
> 
> conftest.c:64:21: fatal error: libutil.h: No such file or directory

Where do you see those?  They look fine if they come from the
config.log: they show you don't have ac_nonexistent.h (which is
obviously expected), that you don't have some OSX headers (which is
expected), and you don't have util.h and libutil.h, but you probably
have pty.h which is an alternative (those are checked by the debugger
and scope plugins).

Again, your issue is most likely due to incorrect GLIB_CFLAGS -- which,
again, is normally auto-detected properly when it's not set.

Regards,
Colomban
_______________________________________________
Users mailing list
Users@lists.geany.org
https://lists.geany.org/cgi-bin/mailman/listinfo/users

Reply via email to