This is just a guess but - is it possible after building slurm against PMIx, you should build openmpi against SLURM's PMIx instead of directly using external? I would assume slurm's PMI server now "knows" PMIx.

On 06/08//2017 16:14, Charles A Taylor wrote:
HI Gilles,

I tried both “—with-pmix=/opt/pmix” and “—with-pmix=internal” and got the same “UNREACHABLE” error both ways.  I tried the “external” first since that is what SLURM was built against.

I’m missing something simple/basic - just not sure what it is.  



On Aug 6, 2017, at 7:43 AM, Gilles Gouaillardet <> wrote:


did you build Open MPI with the external PMIx ?
iirc, Open MPI 2.0.x does not support cross version PMIx



On Sun, Aug 6, 2017 at 7:59 PM, Charles A Taylor <> wrote:

On Aug 6, 2017, at 6:53 AM, Charles A Taylor <> wrote:

Anyone successfully using PMIx with OpenMPI and SLURM?  I have,

1. Installed an “external” version (1.1.5) of PMIx.
2. Patched SLURM 15.08.13 with the SchedMD-provided PMIx patch (results in an mpi_pmix plugin along the lines of mpi_pmi2).
3. Built OpenMPI 2.0.1 (tried 2.0.3 as well).

However, when attempting to launch MPI apps (LAMMPS in this case), I get

  [c9a-s2.ufhpc:08914] PMIX ERROR: UNREACHABLE in file src/client/pmix_client.c at line 199

I should have mentioned that I’m launching with

  srun —mpi=pmix …

If I launch with

 srun —mpi=pmi2 ...

the app starts and runs without issue.

users mailing list
users mailing list
users mailing list

Attachment: smime.p7s
Description: S/MIME Cryptographic Signature

users mailing list

Reply via email to