Using Open-Mpi 3.0 and following the tutorial on this link
I try to run a MPI code under MacOS 10.9.5 (Mavericks) with a number of
process equal to 256 : the MPI code allocates for each process a 512x512 2D
array, so it requires 256*256kB = 64MB of total used memory.

My MacOS has 16GB RAM and 8 cores, so it seems to be weird.

For a number of process lower than 256 (I tried : np=2,4,8,16,32,64,128),
there is no problem, execution is good and I get expected results.

But for np = 256, I get the following message which repeats itself :

$ mpirun -np 256 ./explicitPar

    [warn] select: Invalid argument
    [warn] select: Invalid argument
    [warn] select: Invalid argument

I tried also to use -mca option by doing :

$ mpirun -mca opal_set_max_sys_limits 1 -np 256 ./explicitPar

But I get the same warning message.

>From this link
cited above, I did :

$ launchctl limit maxfiles

  maxfiles    65536          200000

Then, in root user, I created /etc/launchd.conf file and put into :

limit maxfiles 65536 200000

I restarted the system for the new limits to take effect and type as normal
user :

$ launchctl limit maxfiles

maxfiles    65536          200000

But unfortunately, these modifications have no effects on the MPI function
"mpirun" with 256 processes and don't make disappear the warning above.

On Linux platform, I can launch my MPI code with np = 256, without problem,
the issue is only happening on MacOS 10.9.5.

I didn't get this issue with previous version of Open-MPI.

Any idea ? Thanks
users mailing list

Reply via email to