--------------------------------------------
On Tue, 4/10/18, Diego Lin <die...@synnex.com> wrote:

 Subject: RE: How to disable jsf in Eclipse
 To: "Maven Users List" <users@maven.apache.org>, "Karen Goh" 
<karenwo...@yahoo.com>
 Date: Tuesday, April 10, 2018, 2:21 PM
 
 
 If you just want
 to disable JSF in Eclipse, you may modify the project file
 ".project" directly.
 
 Please try this way:
 1. Close
 the project in Eclipse.
 2. Edit the file
 .project to remove all stuff related to JSF, like these:
 
        
 <buildCommand>
            
 <name>org.eclipse.wst.common.project.facet.core.builder</name>
             <arguments>
             </arguments>
         </buildCommand>
 
        
 <nature>org.eclipse.wst.common.project.facet.core.nature</nature>
 3. Open the project again.

It does not work !
 
I did what you said.  And here's how the .project file looks like now 

https://ibb.co/dbnT7H

Still, faces will show....
 
 Thanks,
 Diego
 
 -----Original Message-----
 From: Karen Goh [mailto:karenwo...@yahoo.com.INVALID]
 
 Sent: Tuesday, April 10, 2018 2:13 PM
 To: Maven Users List
 Cc: Diego
 Lin
 Subject: RE: How to disable jsf in
 Eclipse
 
 [External
 E-mail]
 
 
 
 --------------------------------------------
 On Tue, 4/10/18, Diego Lin <die...@synnex.com>
 wrote:
 
  Subject: RE: How to
 disable jsf in Eclipse
  To: "Maven
 Users List" <users@maven.apache.org>,
 "Karen Goh" <karenwo...@yahoo.com>
  Date: Tuesday, April 10, 2018, 1:39 PM
  
  
  please try
 this
  way:
  
  Properties of your
  project
 -> Project Facets -> JavaServer Faces. Uncheck 
 it.
  
 
 It
 does not work!
 
 I did this
 before I tried other things that was mentioned in the
 net.
 
 After I unchecked, I
 would do a Maven update on the project can it would become
 check again........
 
 And so
 the same old url with faces came back again...
 
 
  
  Thanks,
  Diego
  
  
 
 -----Original
  Message-----
 
 From: Karen Goh [mailto:karenwo...@yahoo.com.INVALID]
  
  Sent: Tuesday, April 10,
 2018 1:10 PM
  To: users@maven.apache.org
  Subject: How to disable jsf in Eclipse
  
  [External E-mail]
  
  
  Dear
  expert,
  
  I
 am running a
  maven war plug-in jee project
 using Tomcat and TomEE I  think, with Hibernate and jsp.
  
  Here's my pom.xml :
  
  <project xmlns="http://maven.apache.org/POM/4.0.0";
  xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance";
      xsi:schemaLocation="http://maven.apache.org/POM/4.0.0 
http://maven.apache.org/xsd/maven-4.0.0.xsd";>
     
 
 <modelVersion>4.0.0</modelVersion>
      <groupId>Hi5S</groupId>
     
 
 <artifactId>Hi5S</artifactId>
 
    
 
 <version>0.0.1-SNAPSHOT</version>
     
 
 <packaging>war</packaging>
 
     <build>
     
  <resources>
         
     
  <resource>
   
            
 
 <directory>src/main/resources</directory>
               
 
 <targetPath>WEB-INF</targetPath>
                <includes>
                 
 
 <include>**/*</include>
     
  
          </includes>
           
   
 </resource>
          
      </resources>
   
 </build>
     
 
 <properties>
         
 
 <project.build.sourceEncoding>UTF-8</project.build.sourceEncoding>
          
      
 
 <maven.compiler.source>1.8</maven.compiler.source>
         
 
 <maven.compiler.target>1.8</maven.compiler.target>
  
         
 
 <failOnMissingWebXml>false</failOnMissingWebXml>
  
     
 </properties>
  
 
     <dependencies>
         
 <dependency>
             
 
 <groupId>org.apache.maven.plugins</groupId>
             
 
 <artifactId>maven-war-plugin</artifactId>
             
 
 <version>3.2.0</version>
 
    
      </dependency>
         
  <!-- https://mvnrepository.com/artifact/org.apache.tomcat/tomcat-jdbc
  -->
  
 
        
  <dependency>
             
 
 <groupId>org.apache.tomcat</groupId>
             
 
 <artifactId>tomcat-jdbc</artifactId>
             
 
 <version>9.0.2</version>
 
    
      </dependency>
         
  <!-- https://mvnrepository.com/artifact/org.apache.tomcat/tomcat-jsp-api
  -->
         
  <dependency>
     
        
 
 <groupId>org.apache.tomcat</groupId>
             
 
 <artifactId>tomcat-jsp-api</artifactId>
             
 
 <version>9.0.4</version>
 
    
         
 <scope>provided</scope>
     
     </dependency>
         
 <dependency>
             
 
 <groupId>org.apache.logging.log4j</groupId>
             
 
 <artifactId>log4j-api</artifactId>
             
 
 <version>2.10.0</version>
 
    
      </dependency>
         
 
 <dependency>
             
 
 <groupId>org.apache.logging.log4j</groupId>
             
 
 <artifactId>log4j-core</artifactId>
             
 
 <version>2.10.0</version>
 
    
      </dependency>
         
 
 <dependency>
             
 
 <groupId>javax.servlet</groupId>
             
 
 <artifactId>jstl</artifactId>
 
            
 
 <version>1.2</version>
 
    
      </dependency>
  
          <!--
 datasource-proxy
  -->
 
         <dependency>
     
        
 
 <groupId>commons-digester</groupId>
             
 
 <artifactId>commons-digester</artifactId>
             
 
 <version>2.1</version>
 
    
      </dependency>
         
 
 <dependency>
             
 
 <groupId>commons-logging</groupId>
             
 
 <artifactId>commons-logging</artifactId>
             
 
 <version>1.2</version>
 
    
      </dependency>
         
 
 <dependency>
             
 
 <groupId>javax.servlet</groupId>
             
 
 <artifactId>jsp-api</artifactId>
             
 
 <version>2.0</version>
 
    
         
 <scope>provided</scope>
     
     </dependency>
         
 <dependency>
             
  <groupId>jstl</groupId>
     
         
 <artifactId>jstl</artifactId>
 
            
 
 <scope>provided</scope>
 
    
         
 <version>1.2</version>
     
     </dependency>
         
 <!-- https://mvnrepository.com/artifact/org.apache.logging.log4j/log4j-web
  -->
         
  <dependency>
     
        
 
 <groupId>org.apache.logging.log4j</groupId>
             
 
 <artifactId>log4j-web</artifactId>
             
 
 <version>2.7</version>
 
    
      </dependency>
         
 
 <dependency>
             
 
 <groupId>javax.servlet</groupId>
             
 
 <artifactId>javax.servlet-api</artifactId>
             
 
 <version>3.1.0</version>
 
    
         
 <scope>provided</scope>
     
     </dependency>
         
 <!-- https://mvnrepository.com/artifact/org.apache.tomee/javaee-api
  -->
         
  <dependency>
     
        
 
 <groupId>org.slf4j</groupId>
 
            
 
 <artifactId>slf4j-jdk14</artifactId>
             
 
 <version>1.7.21</version>
 
    
         
 <type>jar</type>
         
    
 
 <scope>compile</scope>
 
    
      </dependency>
         
  <!-- https://mvnrepository.com/artifact/mysql/mysql-connector-java
  -->
         
  <dependency>
     
        
 
 <groupId>mysql</groupId>
 
    
         
 
 <artifactId>mysql-connector-java</artifactId>
             
 
 <version>5.1.45</version>
 
    
         
 <scope>provided</scope>
     
     </dependency>
  
          <!-- https://mvnrepository.com/artifact/javax/javaee-api
  -->
          <!--
 https://mvnrepository.com/artifact/org.hibernate/hibernate-core
  -->
         
  <dependency>
     
        
 
 <groupId>org.hibernate</groupId>
             
 
 <artifactId>hibernate-core</artifactId>
             
 
 <version>5.2.10.Final</version>
 
         </dependency>
     
     <dependency>
         
    
 
 <groupId>javax.validation</groupId>
             
 
 <artifactId>validation-api</artifactId>
             
 
 <version>2.0.0.Final</version>
 
         </dependency>
     
     <dependency>
         
    
 
 <groupId>javax.transaction</groupId>
             
 
 <artifactId>jta</artifactId>
 
            
 
 <version>1.1</version>
 
    
      </dependency>
         
  <!-- https://mvnrepository.com/artifact/javax/javaee-api
  -->
         
  <dependency>
     
        
 
 <groupId>javax</groupId>
 
    
         
 
 <artifactId>javaee-api</artifactId>
             
 
 <version>8.0</version>
 
    
         
 <scope>provided</scope>
     
     </dependency>
         
 <!-- https://mvnrepository.com/artifact/com.google.guava/guava
  -->
         
  <dependency>
     
        
 
 <groupId>com.google.guava</groupId>
             
 
 <artifactId>guava</artifactId>
 
            
 
 <version>19.0</version>
 
    
      </dependency>
         
  <!-- https://mvnrepository.com/artifact/org.javassist/javassist
  -->
         
  <dependency>
     
        
 
 <groupId>org.javassist</groupId>
             
 
 <artifactId>javassist</artifactId>
             
 
 <version>3.19.0-GA</version>
 
         </dependency>
     
     <dependency>
         
    
 
 <groupId>org.apache.geronimo.specs</groupId>
             
 
 <artifactId>geronimo-osgi-locator</artifactId>
             
 
 <version>1.1</version>
 
    
      </dependency><!-- 
https://mvnrepository.com/artifact/org.jboss.logging/jboss-logging
  -->
         
  <dependency>
     
        
 
 <groupId>org.jboss.logging</groupId>
             
 
 <artifactId>jboss-logging</artifactId>
             
 
 <version>3.3.1.Final</version>
 
            
 
 <scope>runtime</scope>
 
    
      </dependency>
         
  <!-- https://mvnrepository.com/artifact/com.fasterxml/classmate
  -->
         
  <dependency>
     
        
 
 <groupId>com.fasterxml</groupId>
             
 
 <artifactId>classmate</artifactId>
             
 
 <version>0.8.0</version>
 
    
      </dependency>
         
  <!-- https://mvnrepository.com/artifact/org.sonatype.aether/aether-api
  -->
         
  <dependency>
     
        
 
 <groupId>org.sonatype.aether</groupId>
             
 
 <artifactId>aether-api</artifactId>
             
 
 <version>1.7</version>
 
    
      </dependency>
     
 
 </dependencies>
  
 
 </project>
  
  I am
 running on Windows 10, Eclipse Oxygen and  Hibernate
 5.2.10.
  
  Recently,
  I have added in persistence.xml file as I want
 to ride of  JPA 'JTP' local resource to do the
 management of  transaction and then I faced this problem of
 my url showing  faces.
  
 
 Also, I created the
  META-INF folder
 manually since it is not there.
  
  Here's my project
 
 structure :
  https://ibb.co/gQPcHH
 
 
  http://localhost:8080/Hi5S/faces/tutorRegister.jsp
  
  (I do not want faces in
 the
  url)
  
 
 Now, I have followed
  the advised as per
 this link below but to no avail.
  
  https://stackoverflow.com/questions/30380941/disable-eclipse-jsf-facet-nature
  
  The guy that mentioned
 the
  method has now switch to use
 Intelligence IDE and I  can't get any help..
  
  Hope someone how to disable
 it.
  
  Thanks a million.
  
  regards,
 
 Karen
  
  
 
 ---------------------------------------------------------------------
  To unsubscribe, e-mail: users-unsubscr...@maven.apache.org
  For additional commands, e-mail: users-h...@maven.apache.org
  
  
  
 
 ---------------------------------------------------------------------
  To unsubscribe, e-mail: users-unsubscr...@maven.apache.org
  For additional commands, e-mail: users-h...@maven.apache.org
  
 
 ---------------------------------------------------------------------
 To unsubscribe, e-mail: users-unsubscr...@maven.apache.org
 For additional commands, e-mail: users-h...@maven.apache.org
 
 
 
 ---------------------------------------------------------------------
 To unsubscribe, e-mail: users-unsubscr...@maven.apache.org
 For additional commands, e-mail: users-h...@maven.apache.org
 

---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscr...@maven.apache.org
For additional commands, e-mail: users-h...@maven.apache.org

Reply via email to