Hi Boudewijn,

First of all, the wiki page you are referring to is a feature page that was 
never implemented.
We are currently working on the same feature, this is the correct feature page:
http://www.ovirt.org/Features/ImportStorageDomain .
I will ask that the irrelevant page be removed to avoid any further confusion.

Second, currently, the only way to import a domain is to create an export 
domain and import it.
Can you get the old setup-up and create an export domain?
If not, we'll try to help and work around this is issue, but this is going to 
be very complex, since this is not supported.

Just to have a general understanding of your setup - your storage on the same 
machine as ovirt engine?

I'm assuming you're using web-admin.
What exactly are you doing there? We don't have the import option there as you 
mentioned, so I don't understand how you could import an SD that was not export.
Adding the entry to /etc/exports is meaningless.

Do you have the ovfs of the old VMs available?
In the meantime checking for an easier solution than the above, will get back 
to you on that.

Regards,
Vered

----- Original Message -----
> From: "Boudewijn Ector" <boudew...@boudewijnector.nl>
> To: users@ovirt.org
> Sent: Sunday, March 9, 2014 3:48:41 AM
> Subject: Re: [Users] Reimporting storage domains after reinstalling ovirt
> 
> On 09-03-14 02:12, Boudewijn Ector wrote:
> > Hi Guys,
> >
> >
> > Currently I've got a Centos machine running the latest ovirt-release.
> > This machine is using a local raid set containing  a directory with
> > ovirt-based VMs from my previous install. The ovirt install is a
> > completely fresh install, no storage/VMs have been created yet.
> >
> > What's the best way to reimport those? I might try to create a new
> > storage domain and copy all old VMs into it (if that works anyway...) ,
> > or just reimport the old domain from the web-interface.
> >
> > Does either trick have any advantage, or is there a best practice I
> > should adhere to?
> >
> >
> > Cheers,
> >
> > Boudewijn
> > _______________________________________________
> > Users mailing list
> > Users@ovirt.org
> > http://lists.ovirt.org/mailman/listinfo/users
> I just tried reimporting my old storage domains but that doesn't seem to
> work:
> 
> [root@server data]# pwd
> /raid/ovirt-old/data
> [root@server data]# ls
> 1979444d-b79a-494c-8c1a-bcc132e31a04  __DIRECT_IO_TEST__
> 
> This is the old data domain I  used, and the
> 1979444d-b79a-494c-8c1a-bcc132e31a04 contains quite a lot of VMs.
> 
> When going to the webinterface and doing :
> - Storage
> - Import domain
>     - Type: NFS
>     - export path: $IP:/raid/ovirt-old/data (and
> $IP:/raid/ovirt-old/data/1979444d-b79a-494c-8c1a-bcc132e31a04)
> 
> Of course I created an entry in /etc/exports in order to be able to
> mount this domain by NFS:
> 
> 
> [root@leiden data]# exportfs
> /raid/ovirt       192.168.1.44/255.255.255.255
> /raid/ovirt-old
>         192.168.1.44/255.255.255.255
> 
> 
> And ownership is by user vdsm.
> 
> Despite of this it doesn't work. Unfortunately this page
> (http://www.ovirt.org/Features/Import_an_existing_Storage_Domain) isn't
> of much use either.
> 
> How should I do this?
> 
> Cheers,
> 
> Boudewijn
> _______________________________________________
> Users mailing list
> Users@ovirt.org
> http://lists.ovirt.org/mailman/listinfo/users
> 
_______________________________________________
Users mailing list
Users@ovirt.org
http://lists.ovirt.org/mailman/listinfo/users

Reply via email to