On Mon, Dec 7, 2015 at 2:59 PM, Taste-Of-IT <kont...@taste-of-it.de> wrote:
> Am 2015-12-07 13:41, schrieb Yedidyah Bar David:
>>
>> On Mon, Dec 7, 2015 at 1:54 PM, Taste-Of-IT <kont...@taste-of-it.de>
>> wrote:
>>>
>>> Am 2015-12-07 11:17, schrieb Yedidyah Bar David:
>>>>
>>>>
>>>> On Mon, Dec 7, 2015 at 11:34 AM, Taste-Of-IT <kont...@taste-of-it.de>
>>>> wrote:
>>>>>
>>>>>
>>>>> Am 2015-12-07 10:21, schrieb Yedidyah Bar David:
>>>>>>
>>>>>>
>>>>>>
>>>>>> On Mon, Dec 7, 2015 at 11:05 AM, Taste-Of-IT <kont...@taste-of-it.de>
>>>>>> wrote:
>>>>>>>
>>>>>>>
>>>>>>>
>>>>>>> Am 2015-12-07 08:06, schrieb Yedidyah Bar David:
>>>>>>>>
>>>>>>>>
>>>>>>>>
>>>>>>>>
>>>>>>>> On Mon, Dec 7, 2015 at 12:38 AM, Taste-Of-IT
>>>>>>>> <kont...@taste-of-it.de>
>>>>>>>> wrote:
>>>>>>>>>
>>>>>>>>>
>>>>>>>>>
>>>>>>>>>
>>>>>>>>> Hello,
>>>>>>>>> i am new with ovirt and i installed ovirt engine 3.6 on centos 7.
>>>>>>>>> After
>>>>>>>>> first login i create the host with fqdn of ovirt server but without
>>>>>>>>> powersavesettings. Firt i saw installing as status for host, but
>>>>>>>>> after
>>>>>>>>> a
>>>>>>>>> while nothing happend, I reboot the server. In engine.log i see
>>>>>>>>> "VMs
>>>>>>>>> initialization finished for Host", but i cant open the webgui. What
>>>>>>>>> can
>>>>>>>>> i
>>>>>>>>> do? Where can i look to find the error and what have i done wrong?
>>>>>>>>
>>>>>>>>
>>>>>>>>
>>>>>>>>
>>>>>>>>
>>>>>>>> If host-deploy managed to finish, you can see its log in [1].
>>>>>>>> Otherwise
>>>>>>>> please try to (re)install the host.
>>>>>>>>
>>>>>>>> [1] /var/log/ovirt-engine/host-deploy/
>>>>>>>>
>>>>>>>> Best,
>>>>>>>
>>>>>>>
>>>>>>>
>>>>>>>
>>>>>>>
>>>>>>> Hi Didi,
>>>>>>> ok i will have a closer look into the log. Actuall the WebGUI doesnt
>>>>>>> load,
>>>>>>> services are up and running. How can i reinstall the host? Via cli?
>>>>>>> Or
>>>>>>> do
>>>>>>> you mean the hostsystem with installed ovirt engine? thx
>>>>>>
>>>>>>
>>>>>>
>>>>>>
>>>>>> Not sure I follow.
>>>>>>
>>>>>> The engine runs on some machine, let's call it "the engine machine".
>>>>>> If it's a self-hosted-engine, it's running inside a VM managed by
>>>>>> itself.
>>>>>> Otherwise it's running elsewhere (on some physical machine, or some
>>>>>> other
>>>>>> VM).
>>>>>>
>>>>>> A "Host", in ovirt terminology, is where VMs run.
>>>>>>
>>>>>> Now please describe what you did, what you now try to do that doesn't
>>>>>> work, and what you can find in logs that might be related.
>>>>>>
>>>>>> If you can't access the web admin ui, that's a completely different
>>>>>> problem than if you can't add a host to the engine.
>>>>>>
>>>>>> Best,
>>>>>
>>>>>
>>>>>
>>>>>
>>>>> Hi Didi,
>>>>> as far i understand there are to ways to setup ovirt. One as
>>>>> self-hosted
>>>>> enginge for ha and with ovirt host in vm on storage
>>>>
>>>>
>>>>
>>>> That's called "self-hosted-engine"
>>>>
>>>>> and hosted engine where
>>>>> all runs on the same host.
>>>>
>>>>
>>>>
>>>> This is called all-in-one [1].
>>>>
>>>> [1] http://www.ovirt.org/Feature/AllInOne
>>>>
>>>>> So i setup hosted engine on same machine and in
>>>>> installation process i setup iso_domain via nfs too. i have done
>>>>> nothing
>>>>> more yet. so as i can see and read from the manual i now have to setup
>>>>> the
>>>>> host,
>>>>
>>>>
>>>>
>>>> No. You are not supposed to setup the host from the web interface.
>>>> I didn't try that recently, but in the past there were issues similar
>>>> to what you wrote below. Please follow the instructions in that page.
>>>> Also please note that in 4.0, allinone will be dropped. Systems that
>>>> wish to have everything on a single host will need to use hosted-engine.
>>>> Also note that people reported locking issues with local nfs mounts, so
>>>> it seems like the safest bet for now is to use nested kvm - run a VM to
>>>> play the "Host" role, and another VM as an nfs server (or iscsi), and
>>>> then either a third VM for the engine, or hosted-engine (meaning, engine
>>>> runs inside a VM running inside the first VM).
>>>>
>>>>> than network and than data domain and so on. now i setup the host and
>>>>> say new, put a name inside and the fqdn of the initial host of host
>>>>> engine
>>>>> like myserver.com. after that i saw the progress which says
>>>>> "installing.." i
>>>>> wait several minutes and after that i got network time out and cant
>>>>> enter
>>>>> the webgui. hope that helps
>>>>
>>>>
>>>>
>>>> Good luck,
>>>
>>>
>>>
>>> Hi,
>>> that sounds not good. As i understand the only way with ovirt from
>>> Version 4
>>> will self-hosted-engine and i have to setup all in nested-vms if i want
>>> or
>>> only can use one machine, right?
>>
>>
>> Not sure I completely followed.
>>
>> allinone will not be supported in 4.
>>
>> hosted-engine will be the only way to install an entire ovirt system on
>> a single machine, _supported_ by ovirt. And as I said, even this one will
>> require an external storage machine.
>>
>> Of course you can use virsh/kvm or whatever other means for creating VMs
>> and use them to setup ovirt.
>>
>>>
>>> Ok i will have to reinstall my testsystem. Is that the way todo:
>>> http://www.ovirt.org/Features/Self_Hosted_Engine?
>>
>>
>> Yes, but you can use the howto [1], which is perhaps more comfortable.
>>
>> [1] http://www.ovirt.org/Hosted_Engine_Howto
>>
>>> So i have to install ovirt
>>> on centos7, than create a kvm with centos for the engine than for the
>>> host
>>> and last a kvm for the nfs and data domain with centos, or better to use
>>> iscsi du to performance? after that i can install the first virtuall
>>> machine,right?
>>
>>
>> Depends on what you want to do.
>>
>> BTW, I didn't mention glusterfs, mainly because I do not know it well,
>> but that's also something to consider.
>>
>>> sounds strange and complicated...
>>
>>
>> ovirt is not designed to manage a single machine. For a single machine,
>> simpler libvirt frontends are easier to use. If you install it just to
>> learn/test, that's how it goes.
>
> Hi,
> ok i have to lunge. i have to migrate from proxmox to another vm-system and
> thing ovirt is just fine while open source.. so i asked in the irc for my
> situation and if ovirt does fit. i have only one server which should run a
> few kvm vm guests (debian, centos, ubuntu...) and also for webservices. in
> the irc they point me to the all-in-solution, i think at that time they
> didnt know that it will not further supporter from version 4 onto.. for my
> situation 2 server are to much but i will later add more server with ha
> usability.

(Re-adding the list, adding Sandro)

The plan for hyper-convergence is to require at least 3 hosts, so that you
have a replica-3 cluster storage.

Perhaps we should reconsider allowing local storage with hosted-engine.
This will prevent HA, but will fit into the place of current allinone
usage. The next stage will be that users will ask to migrate this local
storage to shared one (or even gluster :-) ).

For a 2-cluster HA setup we do not have, or plan to have AFAIK, any
official support, but you can have a look at DRBD [1].

[1] http://www.ovirt.org/Features/DRBD

Best,
-- 
Didi
_______________________________________________
Users mailing list
Users@ovirt.org
http://lists.ovirt.org/mailman/listinfo/users

Reply via email to