> On 24 Jun 2016, at 18:34, Scott <romra...@gmail.com> wrote:
> 
> Actually, I figured out a work around. I changed the HostedEngine VM's 
> vds_group_id in the database to the vds_group_id of my temporary cluster 
> (found from the vds_groups table). This worked and I could put my main 
> cluster in upgrade mode. Now to continue the process...
> 
> 

Note you don’t really need an upgrade mode/policy if you already create a 
temporary cluster. 
Putting aside the HE problem,If you need your other VMs running then you can 
also just cross migrate them to the new el7 cluster (in 3.5 mode). If you have 
many hosts you can just move one by one as you upgrade/reinstall them, and keep 
migrating VMs from the old one to the new depending on your capacity. At the 
end you can just remove the old empty cluster and rename the new one back to 
the original name:)
Shutting down unneeded VMs will save you time

Note that once you have a 3.5 cluster all with el7 hosts in order to upgrade 
the cluster level to 3.6 you anyway need to shut down the VMs in order for 
their configuration changes to happen.

Thanks,
michal
> Thanks,
> Scott
> 
> 
> On Fri, Jun 24, 2016, 9:29 AM Scott <romra...@gmail.com 
> <mailto:romra...@gmail.com>> wrote:
> Hi Roman,
> 
> I made it through step 6 however it does look like the problem you mentioned 
> has occurred.  My engine VM is running on my host in the temporary cluster.  
> The stats under Hosts show this.  But in the Virtual Machines tab this VM 
> still thinks its on my main cluster and I can't change that setting.  Did you 
> have a suggestion on how to work around this?  Thankfully only one of my RHEV 
> instances has this upgrade path.
> 
> Thanks for your help,
> Scott
> 
> On Fri, Jun 24, 2016 at 2:15 AM Roman Mohr <rm...@redhat.com 
> <mailto:rm...@redhat.com>> wrote:
> On Thu, Jun 23, 2016 at 10:26 PM, Scott <romra...@gmail.com 
> <mailto:romra...@gmail.com>> wrote:
> > Hi Roman,
> >
> > Thanks for the detailed steps.  I follow the idea you have outlined and I
> > think its easier than what I thought of (moving my self hosted engine back
> > to physical hardware, upgrading and moving it back to self hosted).  I will
> > give it a spin in my build RHEV cluster tomorrow and let you know how I get
> > on.
> >
> 
> Thanks.
> 
> The bug is here: https://bugzilla.redhat.com/show_bug.cgi?id=1349745 
> <https://bugzilla.redhat.com/show_bug.cgi?id=1349745>.
> 
> I thought about the solution and I see one possible problem with this
> approach. It might be that the engine still thinks that the VM is on
> the old cluster.
> Let me know if this happens, we can work around that too.
> 
> Roman
> 
> > Thanks again,
> > Scott
> >
> > On Thu, Jun 23, 2016 at 2:41 PM Roman Mohr <rm...@redhat.com 
> > <mailto:rm...@redhat.com>> wrote:
> >>
> >> Hi Scott,
> >>
> >> On Thu, Jun 23, 2016 at 8:54 PM, Scott <romra...@gmail.com 
> >> <mailto:romra...@gmail.com>> wrote:
> >> > Hello list,
> >> >
> >> > I'm trying to upgrade a self-hosted engine RHEV environment running
> >> > 3.5/el6
> >> > to 3.6/el7.  I'm following the process outlined in these two documents:
> >> >
> >> >
> >> > https://access.redhat.com/documentation/en-US/Red_Hat_Enterprise_Virtualization/3.6/html/Self-Hosted_Engine_Guide/Upgrading_the_Self-Hosted_Engine_from_6_to_7.html
> >> >  
> >> > <https://access.redhat.com/documentation/en-US/Red_Hat_Enterprise_Virtualization/3.6/html/Self-Hosted_Engine_Guide/Upgrading_the_Self-Hosted_Engine_from_6_to_7.html>
> >> > https://access.redhat.com/solutions/2300331 
> >> > <https://access.redhat.com/solutions/2300331>
> >> >
> >> > The problem I'm having is I don't seem to be able to apply the
> >> > "InClusterUpgrade" policy (procedure 5.5, step 4).  I get the following
> >> > error:
> >> >
> >> > Can not start cluster upgrade mode, see below for details:
> >> > VM HostedEngine with id 5ca9cb38-82e5-4eea-8ff6-e2bc33598211 is
> >> > configured
> >> > to be not migratable.
> >> >
> >> That is correct, only the he-agents on each host decide where the
> >> hosted engine VM can start
> >>
> >> > But the HostedEngine VM is not one I can edit due to being mid-upgrade.
> >> > And
> >> > even if I could, the setting its complaining about can't be managed by
> >> > the
> >> > engine (I tried in another RHEV instance).
> >> >
> >> Also true, it is very limited what you can currently do with the
> >> hosted engine VM.
> >>
> >>
> >> > Is this a bug?  What am I missing to be able to move on?  As it seems
> >> > now,
> >> > the InClusterUpgrade scheduling policy is useless and can't actually be
> >> > used.
> >>
> >> That is indeed something the InClusterUpgrade does not take into
> >> consideration. I will file a bug report.
> >>
> >>  But what you can do is the following:
> >>
> >> You can create a temporary cluster, move one host and the hosted
> >> engine VM there, upgrade all hosts and then start the hosted-engine VM
> >> in the original cluster again.
> >>
> >> The detailed steps are:
> >>
> >> 1) Enter the global maintenance mode
> >> 2) Create a temporary cluster
> >> 3) Put one of the hosted engine hosts which does not currently host
> >> the engine into maintenance
> >> 4) Move this host to the temporary cluster
> >> 5) Stop the hosted-engine-vm with `hosted-engine --destroy-vm` (it
> >> should not come up again since you are in maintenance mode)
> >> 6) Start the hosted-egine-vm with `hosted-engine --start-vm` on the
> >> host in the temporary cluster
> >> 7) Now you can enable the InClusterUpgrade policy on your main cluster
> >> 7) Proceed with your main cluster like described in
> >>
> >> https://access.redhat.com/documentation/en-US/Red_Hat_Enterprise_Virtualization/3.6/html/Self-Hosted_Engine_Guide/Upgrading_the_Self-Hosted_Engine_from_6_to_7.html
> >>  
> >> <https://access.redhat.com/documentation/en-US/Red_Hat_Enterprise_Virtualization/3.6/html/Self-Hosted_Engine_Guide/Upgrading_the_Self-Hosted_Engine_from_6_to_7.html>
> >> 8) When all hosts are upgraded and InClusterUpgrade policy is disabled
> >> again, move the hosted-engine-vm back to the original cluster
> >> 9) Upgrade the last host
> >> 10) Migrate the last host back
> >> 11) Delete the temporary cluster
> >> 12) Deactivate maintenance mode
> >>
> >> Adding Sandro and Roy to keep me honest.
> >>
> >> Roman
> >>
> >> >
> >> > Thanks for any suggestions/help,
> >> > Scott
> >> >
> >> > _______________________________________________
> >> > Users mailing list
> >> > Users@ovirt.org <mailto:Users@ovirt.org>
> >> > http://lists.ovirt.org/mailman/listinfo/users 
> >> > <http://lists.ovirt.org/mailman/listinfo/users>
> >> >
> _______________________________________________
> Users mailing list
> Users@ovirt.org
> http://lists.ovirt.org/mailman/listinfo/users

_______________________________________________
Users mailing list
Users@ovirt.org
http://lists.ovirt.org/mailman/listinfo/users

Reply via email to