On 05/10/2017 10:47 PM, Joel Diaz wrote:
I though I would try something different so I removed the key group and value virt when creating the volumes. I was able to create the volumes. I stopped the data volume. I then tried to set the volume group by issuing a "gluster volume data group virt"

Still get "unable to open file '/var/lib/gluster/Virt'. Error: No such file or directory.

I don't know if I should continue with the setup until I can set this value.

Please let me know if I can provide some logs to identify the issue.

Thanks for your help,

Joel

On May 10, 2017 6:57 AM, "Joel Diaz" <mrjoeld...@gmail.com <mailto:mrjoeld...@gmail.com>> wrote:

    Thanks for the reply.

    The file is empty. I created the file by issuing a "touch
    /var/lib/glusterd/groups/virt"

    The first time I attempted to set the group volume, the error was
    that the file was missing. I read a bug report that advised to
    remove and reinstall the gluster package in order to properly
    recreate the file. Since that did not work, I created it manually.

    Thank you,

    Joel

Hi Joel,

Do you have this file present on the system ? This file will be present when glusterfs is installed. I would like to first understand how is it missing on your system? The error is because i see that you do not have the file present there. Can you please paste output of "ls -l /var/lib/glusterd/groups/virt" ?


Thanks
kasturi


    On Wed, May 10, 2017 at 2:12 AM, knarra <kna...@redhat.com
    <mailto:kna...@redhat.com>> wrote:

        On 05/10/2017 06:37 AM, Joel Diaz wrote:
        Hello ovirt users,

        First off all, thanks for your work. I've been using the
        software for a few months and the experience has been great.

        I'm having a hard time trying to set the group on a glusterfs
        volume

        PLAY [master]
        ******************************************************************

        TASK [Sets options for volume]
        *************************************************
        failed: [192.168.170.141] (item={u'key': u'group', u'value':
        u'virt'}) => {"failed": true, "item": {"key": "group",
        "value": "virt"}, "msg": "'/var/lib/glusterd/groups/virt'
        file format not valid.\n"}
        From this error it looks like the virt file format is not
        valid? Can you please paste the contents of this file?
        changed: [192.168.170.141] => (item={u'key':
        u'storage.owner-uid', u'value': u'36'})
        changed: [192.168.170.141] => (item={u'key':
        u'storage.owner-gid', u'value': u'36'})
        changed: [192.168.170.141] => (item={u'key':
        u'network.ping-timeout', u'value': u'30'})
        changed: [192.168.170.141] => (item={u'key':
        u'performance.strict-o-direct', u'value': u'on'})
        changed: [192.168.170.141] => (item={u'key':
        u'network.remote-dio', u'value': u'off'})
        changed: [192.168.170.141] => (item={u'key':
        u'cluster.granular-entry-heal', u'value': u'enable'})
                to retry, use: --limit
        @/tmp/tmpdTWQ8B/gluster-volume-set.retry

        PLAY RECAP
        *********************************************************************
        192.168.170.141            : ok=0  changed=0    unreachable=0
           failed=1

        I've tried to remove remove glusterfs, wiping the glusterfs
        configurations and reinstalling the service.

        Any help would be appreciated.

        Thank you,

        Joel


        _______________________________________________
        Users mailing list
        Users@ovirt.org <mailto:Users@ovirt.org>
        http://lists.ovirt.org/mailman/listinfo/users
        <http://lists.ovirt.org/mailman/listinfo/users>

_______________________________________________
Users mailing list
Users@ovirt.org
http://lists.ovirt.org/mailman/listinfo/users

Reply via email to