Hello,

i have installed one oVirt platform with 2 node and 1 HE version 4.2.1.7-1

It seem to work fine, but i would like more information on the guest agent.
For the HE, the guest agent seem to be OK, on this vm i 've spotted that the 
ovirt-guest-agent and qemu-guest-agent are installed.

I have 2 VM, 1 debian 9 and 1 RHEL 6.5. I've tried to install the same service 
on each VM, but the result is the same :
no info about IP, fqdn, or app installed for these vm, and there is a orange ! 
for each vm on the web ui (indicate that i need to install latest guest agent) .

I have tried different test with spice-vdagent, or ovirt-guest-agent or 
qemu-guest-agent but no way.

ovirt-guest-agent doesn't start on debian 9 and RHEL 6.5 :
MainThread::INFO::2018-03-11 
22:46:02,984::ovirt-guest-agent::59::root::Starting oVirt guest 
agentMainThread::ERROR::2018-03-11 
22:46:02,986::ovirt-guest-agent::141::root::Unhandled exception in oVirt guest 
agent!Traceback (most recent call last):  File 
"/usr/share/ovirt-guest-agent/ovirt-guest-agent.py", line 135, in <module>    
agent.run(daemon, pidfile)  File 
"/usr/share/ovirt-guest-agent/ovirt-guest-agent.py", line 65, in run    
self.agent = LinuxVdsAgent(config)  File 
"/usr/share/ovirt-guest-agent/GuestAgentLinux2.py", line 472, in __init__    
AgentLogicBase.__init__(self, config)  File 
"/usr/share/ovirt-guest-agent/OVirtAgentLogic.py", line 188, in __init__    
self.vio = VirtIoChannel(config.get("virtio", "device"))  File 
"/usr/share/ovirt-guest-agent/VirtIoChannel.py", line 153, in __init__    
self._stream = VirtIoStream(vport_name)  File 
"/usr/share/ovirt-guest-agent/VirtIoChannel.py", line 134, in __init__    
self._vport = os.open(vport_name, os.O_RDWR)OSError: [Errno 2] No such file or 
directory: '/dev/virtio-ports/com.redhat.rhevm.vdsm'


Can i have help for this problem ?

Thanks.

Nicolas VAYE
DSI - Nouméa
NEW CALEDONIA
_______________________________________________
Users mailing list
Users@ovirt.org
http://lists.ovirt.org/mailman/listinfo/users

Reply via email to