Hi Arik,
unfortunatly I couldn't discuss last friday with a colleague who needs to work 
on the cluster this week-end. Discovering the freezed tasks, he found a 
workaround by deleting the lines in the job table, and the tasks disappear in 
the GUI. Then... He drops the faulty VM :(
But, I have shared the engine.log of april 11 and 12. The export to OVA of the 
"CO7_VM1" vm was lauched around 17:01, with other vms (to the same directory on 
host "victor"). Other vms exports end successfully but not this one.
Another export of the same vm was launched on april 12 at 10:42, to see if it 
says "already working"... But it didn't, and the second task rans with the 
first, indefinitly. 
This links are active for 2 days :
I've not seen something revelant in it, but have a look ?

This morning I tried to reproduce the problem. I've create a vm from template 
(50G). Migrate it : OK. Export it to OVA : OK.
I then extended the disk to 100G, then tested again. Migrate it : OK. Export it 
to OVA...... OK :( So I wasn't able to reproduce the error.

Le Vendredi, Avril 13, 2018 21:53 CEST, Arik Hadas <aha...@redhat.com> a écrit: 
  On Fri, Apr 13, 2018 at 6:54 PM, fsoyer <fso...@systea.fr> wrote:Hi,
This task is listed (since 2 days) in the GUI / up right "tasks" icon. It is 
visibly freezed as no OVA file has been created, but no errors in GUI, just... 
it runs. Or : it loops :)
This (test) vm is one on which I have extended the disk (50 -> 100G). Before 
being stopped and trying to export it to OVA, it works fine. All other vms 
around can be well exported but not this one. I've tried to restart engine, 
change SPM, restart one by one each node, but the task is always here. I could 
even restart the vm today without error and it works fine ! But... the task 
Today also, I tried to clone the vm : same thing, now I have 2 tasks running 
indefinitly :( 
Strange bug, where no timeout stopped the tasks in error. I can't see any 
revelant things in engine.log or vdsm.log, but probably I've not seen them in 
all the messages.
No problem to remove this (test) vm and try on another (test) one (extend disk 
to see if this is the reason of the problem). But before I want to kill this 
tasks ! Please don't remove that VM yet.It would be appreciated if you could 
file a bug and share the engine log that covers the attempt to export this VM 
to OVA + the ansible log of that operation. 

 Le Vendredi, Avril 13, 2018 16:24 CEST, Arik Hadas <aha...@redhat.com> a écrit:
   On Fri, Apr 13, 2018 at 11:14 AM, fsoyer <fso...@systea.fr> wrote:Hi all,
I can't find any exhaustive doc for new vdsm-client. My problem actually is a 
task (export a vm to OVA) blocked. I'm afraid you won't find any task in VDSM 
for 'export a VM to OVA'.Expoting a VM to OVA is comprised of three steps:1. 
Creating temporary cloned disks - you'll find a task of copy-image-group for 
each disk.2. Creating the OVA file - that's done by a python script executed by 
ansible, there is no task for that in VDSM.3. Removing the temporary cloned 
disks - you'll find a task of remove-image for each disk. Can you please 
elaborate on the problem you're having - where do you see that task and how can 
you see that it's blocked? I found that I can interact with
vdsm-client Task getInfo taskID=<uuid>, and replace getInfo by "stop", BUT : 
how can I find this UUID ???
Old "vdsClient -s 0 getAllTasksStatuses" has no equivalent ??

Does someone knows if a complete doc exists dot vdsm-client ?


Le Mercredi, Janvier 25, 2017 12:30 CET, Irit Goihman <igoih...@redhat.com> a 
 Hi All, vdsClient will be removed from master branch today.It is using XMLRPC 
protocol which has been deprecated and replaced by JSON-RPC. A new client for 
vdsm was introduced in 4.1: vdsm-client.This is a simple client that uses 
JSON-RPC protocol which was introduced in ovirt 3.5. The client is not aware of 
the available methods and parameters, and you should consult the schema [1] in 
order to construct the desired command. Future version should parse the schema 
and provide online help.  If you're using vdsClient, we will be happy to assist 
you in migrating to the new vdsm client.   vdsm-client usage: vdsm-client [-h] 
[-a ADDRESS] [-p PORT] [--unsecure] [--timeout TIMEOUT]                   [-f 
FILE] namespace method [name=value [name=value] ...]  Invoking simple methods: 
# vdsm-client Host getVMList['b3f6fa00-b315-4ad4-8108-f73da817b5c5'] For 
invoking methods with many or complex parameters, you can read the parameters 
from a JSON format file: # vdsm-client Lease info -f lease.json where 
lease.json file content is: {                                                   
                                   "lease": {                                   
"lease_id": "b3f6fa00-b315-4ad4-8108-f73da817b5c5"                             
}                                                                          }   
It is also possible to read parameters from standard input, creating complex 
parameters interactively: # cat <<EOF | vdsm-client Lease info -f -             
                                  "lease": {                                    
"lease_id": "b3f6fa00-b315-4ad4-8108-f73da817b5c5"                            } 
EOF    Constructing a command from vdsm schema: Let's take VM.getStats as an 
example.This is the entry in the schema: VM.getStats:                           
                                             added: '3.1'                       
                                             description: Get statistics about 
a running virtual machine.                    params:                           
                                              -   description: The UUID of the 
VM                                                 name: vmID                   
                                                   type: *UUID                  
                                                   description: An array 
containing a single VmStats record                        type:                 
                                                          - *VmStats            
                                                   namespace: VMmethod name: 
getStatsparams: vmID The vdsm-client command is: # vdsm-client VM getStats 
vmID=b3f6fa00-b315-4ad4-8108-f73da817b5c5  Invoking getVdsCaps command: # 
vdsm-client Host getCapabilities   Please consult vdsm-client help and man page 
for further details and options.   [1] 
https://github.com/oVirt/vdsm/blob/master/lib/api/vdsm-api.yml --Irit 
GoihmanSoftware EngineerRed Hat Israel Ltd.

Users mailing list

Users mailing list

Reply via email to