On Mon, Apr 16, 2018 at 12:18 PM, <dhy...@sina.com> wrote:

> Hi Simone
> Thanks, I disble selinux, the issue is work, but  has other issue,
> error is:
>
> [ INFO  ] Engine is still unreachable
> [ INFO  ] Engine is still not reachable, waiting...
> [ INFO  ] Engine is still unreachable
> [ ERROR ] Engine is still not reachable
> [ ERROR ] Failed to execute stage 'Closing up': Engine is still not
> reachable
> [ INFO  ] Stage: Clean up
> [ INFO  ] Generating answer file '/var/lib/ovirt-hosted-engine-
> setup/answers/answers-20180416095044.conf'
>
> when #hosted-engine --deploy  I setup static ip, and set ip in /etc/hosts.
> VM`s ip is same with that i set.
>
>
Can you please check the status of ovirt-engine service on the engine VM?


>
>
>
>
>
>
> ----- 原始邮件 -----
> 发件人:Simone Tiraboschi <stira...@redhat.com>
> 收件人:dhy...@sina.com
> 抄送人:users <users@ovirt.org>
> 主题:Re: [ovirt-users] hosted-engine --deploy failed
> 日期:2018年04月16日 15点24分
>
> 2018-04-16 05:50:09,331+0800 DEBUG otopi.plugins.otopi.network.firewalld
> plugin.executeRaw:813 execute: ('/usr/bin/firewall-cmd',
> '--list-all-zones'), executable='None', cwd='None', env=None
> 2018-04-16 14:21:26,331+0800 DEBUG otopi.plugins.otopi.network.firewalld
> plugin.executeRaw:869 execute-result: ('/usr/bin/firewall-cmd',
> '--list-all-zones'), exception
>
> 'firewall-cmd --list-all-zones' got stuck on the engine VM; we had
> similar issue in the past to SELinux rues.
> If you are deploying with a custom cloud-init ISO image with custom script
> please try disabling SELinux there just for engine-setup execution time.
>
>
> As a general rule I'd suggest to move instead to the new ansible based
> flow where engine-setup is executed via ansible in a more controllable way.
>
> On Mon, Apr 16, 2018 at 8:44 AM, <dhy...@sina.com> wrote:
>
> Hi,
>  when I depoy hosted engine by #hosted-engine --deploy
>
>           |- [ INFO  ] Stage: Transaction setup
>           |- [ INFO  ] Stopping engine service
>           |- [ INFO  ] Stopping ovirt-fence-kdump-listener service
>           |- [ INFO  ] Stopping dwh service
>           |- [ INFO  ] Stopping Image I/O Proxy service
>           |- [ INFO  ] Stopping vmconsole-proxy service
>           |- [ INFO  ] Stopping websocket-proxy service
>           |- [ INFO  ] Stage: Misc configuration
>           [ ERROR ] Engine setup got stuck on the appliance
>           [ ERROR ] Failed to execute stage 'Closing up': Engine setup is
> stalled on the appliance since 1800 seconds ago. Please               check
> its log on the appliance.
>           [ INFO  ] Stage: Clean up
>           [ INFO  ] Generating answer file '/var/lib/ovirt-hosted-engine-
> setup/answers/answers-20180416062012.conf'
>           [ INFO  ] Stage: Pre-termination
>           [ INFO  ] Stage: Termination
>           [ ERROR ] Hosted Engine deployment failed: this system is not
> reliable, please check the issue,fix and redeploy
>           Log file is located at /var/log/ovirt-hosted-engine-s
> etup/ovirt-hosted-engine-setup-20180416054143-5p2ilc.log
>
> engine-setup take a lot time in "Stage: Misc configuration", and finaly
> failed.
>
> My mail attachment is hosted-engine --deploy log and VM engine-setup log.
>
> would you give me some advise?  Thanks...
>
>
>
>
> _______________________________________________
> Users mailing list
> Users@ovirt.org
> http://lists.ovirt.org/mailman/listinfo/users
>
>
>
_______________________________________________
Users mailing list
Users@ovirt.org
http://lists.ovirt.org/mailman/listinfo/users

Reply via email to