On Thu, Aug 22, 2019 at 11:31 AM <tho...@hoberg.net> wrote:
>
> Of course a desktop on a virtualization host isn't really recommended, but 
> actually, managing highly or even high-available supports services as VMs on 
> a set of fat workstations under the control of oVirt can be rather useful...
>
> And I prefer Cinnamon so much over the other desktops, it gets installed 
> almost first after setup... Which turns out to be a mistake with oVirt.
>
> Anyhow, to make a long journey of hair-pulling root-cause searching short:
> Installing Cinnamon from EPEL has Otopi not find rpmUtils for one reason or 
> another, even if I can see it on both sides, the engine and the target host.

Which OSes on each of them? Which python versions? Other stuff from
EPEL? What version of oVirt?

Having all of EPEL enabled is known to have caused problems in the
past, and is not recommended, nor tested (other than by people like
you :-) ).
You might try to carefully enable only Cinnamon and its dependencies
and see what you can come up with.

>
> Remove Cinnamon, it works again and you can re-install Cinnamon after.
> I didn't test re-deploys, but I'd expect them to fail.
>
> Don't know if this should be a bug report, since Cinnamon very unfortunately 
> doesn't seem official just yet.
>
> This is what you may expect to see in the engine logs:
>
> 2019-08-22 09:49:24,152+0200 DEBUG otopi.context context._executeMethod:145 
> method exception
> Traceback (most recent call last):
>   File "/tmp/ovirt-BAJG2FYLMu/pythonlib/otopi/context.py", line 132, in 
> _executeMethod
>     method['method']()
>   File 
> "/tmp/ovirt-BAJG2FYLMu/otopi-plugins/ovirt-host-deploy/kdump/packages.py", 
> line 216, in _customization
>     self._kexec_tools_version_supported()
>   File 
> "/tmp/ovirt-BAJG2FYLMu/otopi-plugins/ovirt-host-deploy/kdump/packages.py", 
> line 143, in _kexec_tools_version_supported
>     from rpmUtils.miscutils import compareEVR
> ModuleNotFoundError: No module named 'rpmUtils'
> 2019-08-22 09:49:24,152+0200 ERROR otopi.context context._executeMethod:154 
> Failed to execute stage 'Environment customization': No module named 
> 'rpmUtils'

This might be this known bug:

https://bugzilla.redhat.com/show_bug.cgi?id=1724056

Can't tell how it's triggered by adding EPEL.

If you think it's a different bug, by all means - please report it!
Thanks. And please attach relevant info, logs, etc.

Good luck and best regards,
-- 
Didi
_______________________________________________
Users mailing list -- users@ovirt.org
To unsubscribe send an email to users-le...@ovirt.org
Privacy Statement: https://www.ovirt.org/site/privacy-policy/
oVirt Code of Conduct: 
https://www.ovirt.org/community/about/community-guidelines/
List Archives: 
https://lists.ovirt.org/archives/list/users@ovirt.org/message/5B72ZDFFKLJMYSDETNQVB4CCQENH3I5L/

Reply via email to