Ah, sorry, I should have been more precise in my qestion. Osinfo was somehow 
damaget on our side, I'm sure.

I mean the UI problem. This one:

> The problem actually looks somewhat related to UI. I've tried to _not_ change 
> anything on "Edit Cluster" dialogue window and just pressed "OK" and still 
> got the "Error while executing action: Cannot disable gluster service on the 
> cluster as it contains volumes" response.
> By looking on UI I see that "Enable Gluster Service" checkbox is empty and is 
> grayed out. Looks like UI "thinks" that Glusterfs is disabled and when I hit 
> "OK" it tries to apply this as a change.
> I've checked engine-config:
> [root@he ~]# engine-config -g AllowClusterWithVirtGlusterEnabled
> Picked up JAVA_TOOL_OPTIONS: -Dcom.redhat.fips=false
> AllowClusterWithVirtGlusterEnabled: true version: general
> It is "True". And it is protected. I was unable to set it to "False" - just 
> tried out of curiosity.
> Next I've opened Web Developer Tools in my browser, found '<input 
> type="checkbox" value="on" id="ClusterPopupView_enableGlusterService" 
> tabindex="17" disabled="" style="vertical-align: top;">' and removed the word 
> 'disabled'. I've checked this checkbox and tried hitting "OK".
> This time the dialog worked and after reopening it I see the checkbox grayed 
> out but now it is checked. oVirt works, nothing is changed or ruined. But one 
> more observation: this checkbox stays checked till Hosted Engine reboot. 
> After a reboot it is unchecked again.
Users mailing list -- users@ovirt.org
To unsubscribe send an email to users-le...@ovirt.org
Privacy Statement: https://www.ovirt.org/privacy-policy.html
oVirt Code of Conduct: 
List Archives: 

Reply via email to