The proton ruby gem and package are incorrectly named according to the
standard gem naming rules, see
https://issues.apache.org/jira/browse/PROTON-1760 for details.
The short story is we want to change the name from "qpid_proton" to
"qpid-proton" for the next release (0.22, not the 0.21 release in progress)
The impact is that code using the package would need to change lines
`require 'qpid_proton'` to `require 'qpid-proton'`. It's annoying, but it
seems best to get it right as quickly as possible.
The plan is be to leave the "qpid_proton" gem available, but stalled at
version 0.21. Code using the "qpid_proton" gem won't break but to avail of
future updates you'll need to switch to using the "qpid-proton" gem
instead. If you're using ruby from a downloaded source package or git clone
you'll need to update your code to use the 0.22 release.
I'll make the change next week - I want to make it early in the release
cycle so we have time to find and iron out problems. If anyone has
questions, problems or suggestions about how to make the transition
smoother please respond to the list or comment on the JIRA