I've a quite standard SOGo 2.2.9 installation on a Ubuntu 14.04 system,
installed from inverse.ca apt source. The only specific aspect is that
I'm getting the users from a postfixadmin database view (mysql backend).
It's working very well (thanks guys!) apart from some spurious complains
from the cron jobs (/usr/sbin/sogo-tool expire-sessions 60 and
/usr/sbin/sogo-ealarms-notify). Both are saying at random instants (once
per day or so):

Failed to create lock directory

The directory /var/lib/sogo/GNUstep/Defaults/.lck/ is owned by sogo:sogo
and the cron jobs are the standard ones from /etc/cron.d/sogo, run under
the sogo uid (as far as I can tell).

I've tried to reproduce the problem from the command line with no luck.
The only reasonable explanation that came to my mind would be a race
between sogo-tool and sogo-ealarms-notify, as they run both every
minute, but I'm not even sure this is possible. I'm testing chaining the
commands as

* * * * *      sogo     /usr/sbin/sogo-ealarms-notify &&
/usr/sbin/sogo-tool expire-sessions 60

to see if this changes anything.

I've tried to create the lock directory mentioned in the message. It
survives until the next call to one of those commands and then is deleted.

Meanwhile, what can I do to investigate this further? Any particular
configuration variable to check? I've added the -v option to sogo-tool
with no particular gain. Permissions?

I hope this is not a FAQ, I searched in the archives and on the website
with no luck...



Reply via email to