I'm facing to a very weird problem about SOGo and MySQL.
I had a SOGo server working correctly with no problem, but I had to
reboot the server. After that I restarted Sogod, MariaDB, memcache,
Apache, and the other services, but now sogo is unable to use
MySQL/MariaDB. I have this kind of error in my logs messages :

2015-04-08 8:18:58.708 sogod[8174]  ERROR((null)): could not allocate
MySQL4 connection!
Apr 08 8:18:58 sogod [8174]: [ERROR]
<0x0x7f3a2c9564f0[GCSChannelManager]> could not open channel
<MySQL4Channel[0x0x7f3a2ce4e490] connection=0x(null)> for
Apr 08 8:18:58 sogod [8174]: [WARN]
<0x0x7f3a2c9564f0[GCSChannelManager]>   will prevent opening of this
channel 5 seconds after 2015-04-08 8:18:58 +0200
Apr 08 8:18:58 sogod [8174]: [ERROR] <0x0x7f3a2c8fb050[SQLSource]>
failed to acquire channel for URL:

However :
* it worked well before the reboot,
* I am able to be connected to my db with "mysql -h localhost -u sogo -p",
* when I do "telnet localhost 3306" I have a opened connection to
MariaDB (the connection is accepted and there is a kind of welcome message)
* the port used by MariaDB is still the same,
* and I even configured iptable for having the 3306 port open to everybody.
What did I forget ?

Best regards

Reply via email to