Thanks for your reply:
Answer to your previous question:  1). since the loadbalance haven't been 
triggered, so I think we can ignore it now. 
2). You are right "missing uri map" is a debug information, but  in the above 
code I pasted, it will return DECLINED, which is actually an error case.
3). the hostname doesn’t match with the configuration file, since I modified 
some conf, so I tried to copy the original one used on 1.2.32. sorry for the 
4). I don't know ajp12, it's not triggered yet in my testing.

I attached the configuration files in my lab, this setting worked if using 
mod_jk 1.2.23 release.  If I replace the with the version 1.2.40, 
then it failed to open the page /sso/lsm/lsm.jnlp ( I got "Not Found  The 
requested URL /sso/lsm/lsm.jnlp was not found on this server.").

I opened the debug of mod_jk, I noticed it added into some uri work map and 
also it can be dumped into jk.log:

[Wed Mar 16 12:47:17.965 2016] [12184:139831250073568] [debug] 
uri_worker_map_add::jk_uri_worker_map.c (863): exact rule '/sso=csajboss' 
source 'JkMount' was added
[Wed Mar 16 12:47:17.965 2016] [12184:139831250073568] [debug] 
uri_worker_map_add::jk_uri_worker_map.c (854): wildchar rule '/sso/*=csajboss' 
source 'JkMount' was added
[Wed Mar 16 12:47:17.974 2016] [12185:139831250073568] [debug] 
uri_worker_map_dump::jk_uri_worker_map.c (197): NEXT (1) map #10: uri=/sso/* 
worker=csajboss context=/sso/* source=JkMount type=Wildchar len=6
[Wed Mar 16 12:47:17.974 2016] [12185:139831250073568] [debug] 
uri_worker_map_dump::jk_uri_worker_map.c (197): NEXT (1) map #20: uri=/sso 
worker=csajboss context=/sso source=JkMount type=Exact len=4

But later when I tried to open the sso/lsm/lsm.jnlp, it should match the 
wildchar /sso/* uri map.  But it was failed, from the code, it's failed in 
mod_jk.c jk_translate method()
The conf->wu_map was null(don't know why ??), 

           if (!conf->uw_map) {
                if (JK_IS_DEBUG_LEVEL(conf->log))
                    jk_log(conf->log, JK_LOG_DEBUG,
                           "missing uri map for %s:%s",
                           conf->s->server_hostname ? conf->s->server_hostname 
: "_default_",
                return DECLINED;
            else {
                rule_extension_t *e;
                worker = map_uri_to_worker_ext(conf->uw_map, r->uri,
                                               NULL, &e, NULL, conf->log);
                rconf->rule_extensions = e;
                ap_set_module_config(r->request_config, &jk_module, rconf);

Do I need to change some configuration after upgrade to 1.2.40?

-----Original Message-----
From: André Warnier (tomcat) [] 
Sent: Monday, March 14, 2016 7:50 PM
To: Tomcat Users List
Subject: [COMMERCIAL] Re: [COMMERCIAL] Re: Need Help: - jk doesn't work after 
upgrade to1.2.40 from 1.2.23

Hi Eric.

A couple of things :
1) Martin is right, in the sense that if a "worker" is mentioned in the 
loadbalancer configuration ("balance_workers"), then normally you should /not/ 
also list it in the list of individual "workers" in the "worker.list" directive.
2) I am not even sure that you really have a problem : the logfile part that 
you are showing, shows "[debug]" lines with the "Missing URI map.." messages.
These are not errors (otherwise they would be marked "[error]"), they are trace 
messages allowing you to figure out what is going on when debugging a problem.
A "missing URI map" just indicates that mod_jk is trying to match the URI of 
the current request with one of the "JkMount" URI's, and failing *for the 
worker which it is now trying to match*.  That does not necessarily mean that 
it will fail to match this URI with some other worker.
3) the debug messages show a prefix like "IBM001OAM01:". What does that 
correspond to ? I do not see this name in the JkMount directives that you show, 
nor in the part of that you show.
4) I am a bit puzzled by this section :
 >>> worker.ajp12.port=8007
 >>> worker.ajp12.type=ajp12

What is this type "ajp12" ? As far as I know, this does not exist, see
Mandatory Directives -> type

And finally, do you have a problem, and what is it ?
What really happens when you try to access a URI like 
"http://(hostname)/sso/lsm/lsm.jnlp" ?

And could you provide a *complete* list of your (Jk*) configuration directives, 
and a complete content of the file ?
And maybe a short description as to what you are trying to achieve.
 From what you provided so far, it is not very clear which URI's you want to 
"load-balance" and which not.
The fact that "it worked before" is no guarantee that what you had before was 
entirely correct.

On 14.03.2016 11:47, Martin Knoblauch wrote:
> Hi Eric,
>   there are two things different from *my* working "mod_jk/1.2.41" setup:
> a) I have only the "JkMount /xxx/* xxx" line in my configuration
> b) in the workers list I have only the loadbalancer and the management 
> workers listed, not the individual ones. Not sure how relevant this is
> Martin
> On Mon, Mar 14, 2016 at 8:24 AM, ZHAO Eric 
> <>
> wrote:
>> Dear Andre,
>> Thanks for your response!
>> We didn't use Virtual Host in our setting.  I re-read the 
>> documentation and didn't find anything wrong with the setting, also 
>> this setting worked before. Do you have several minutes to check the 
>> setting in our server for mod_jk?  Appreciate for your time.
>> Best Regards,
>> Eric.
>> -----Original Message-----
>> From: André Warnier (tomcat) []
>> Sent: Saturday, March 12, 2016 10:18 PM
>> To:
>> Subject: [COMMERCIAL] Re: Need Help: - jk doesn't work after upgrade 
>> to
>> 1.2.40 from 1.2.23
>> On 12.03.2016 15:04, ZHAO Eric wrote:
>>> Hello,
>>> I am new to Tomcat Connectors, we are trying to upgrade the existing
>> mod_jk 1.2.23 to 1.2.40 for IPV6 configuration.
>>> But we always got the following error in jk.log with 1.2.40, we 
>>> don't
>> know if anything need to adjust after upgrade to the new version:
>>> [Thu Mar 10 17:45:10.790 2016] [13878:140261127514080] [debug] 
>>> jk_translate::mod_jk.c (3855): missing uri map for 
>>> IBM001OAM01:/sso/lsm/lsm.jnlp [Thu Mar 10 17:45:10.790 2016] 
>>> [13878:140261127514080] [debug] jk_map_to_storage::mod_jk.c (4023):
>>> missing uri map for IBM001OAM01:/sso/lsm/lsm.jnlp
>>> Can some one help me out from this issue? Appreciated in advance, 
>>> the
>> following are the setting, we don't have file..
>>> Here is our setting for mod_jk:
>>> mod_jk.conf:
>>> <IfModule !mod_jk.c>
>>>     LoadModule jk_module /usr/lib64/httpd/modules/
>>> </IfModule>
>>> JkWorkersFile /etc/httpd/conf/
>>> JkLogFile /var/log/jk.log
>>> # JkLogLevel debug
>>> JkLogLevel warning
>>> JkMount /MIBS ajp12
>>> JkMount /MIBS/* ajp12
>>> ...
>>> JkMount /sso csajboss
>>> JkMount /sso/* csajboss
>>> worker.list=ajp12,soapnbi,csajboss,csawebsso,loadbalancer,cfmaplayer
>>> 1,
>>> cfmaplayer2,cfmaplayer3
>>> worker.ajp12.port=8007
>>> worker.ajp12.type=ajp12
>>> # Added for SOAP NBI
>>> worker.soapnbi.port=8009
>>> worker.soapnbi.type=ajp13
>>> # Added for CSA - JBOSS
>>> worker.csajboss.port=8011
>>> worker.csajboss.type=ajp13
>>> #// next are lb related.
>> Does this happen in an Apache httpd VirtualHost ?
>> If yes, make sure that you re-read the configuration documentation at 
>> and in particular, the sections about JkMount and JkMountCopy.
>> ---------------------------------------------------------------------
>> To unsubscribe, e-mail:
>> For additional commands, e-mail:
>> ---------------------------------------------------------------------
>> To unsubscribe, e-mail:
>> For additional commands, e-mail:

To unsubscribe, e-mail:
For additional commands, e-mail:

To unsubscribe, e-mail:
For additional commands, e-mail:

Reply via email to