On Tuesday, August 27, 2019 7:41 PM Juan Ramirez wrote:
>I'm currently having an issue with starting Tomcat 9.0.24 32-bit version as a 
>service. After installing Tomcat9 using the windows service installer, I try 
>to run Tomcat9 and get the windows service error:
>"Windows could not start Tomcat9 service on Local Computer. Error 1067: The 
>process terminated unexpectedly." I tried looking in the logs to see what 
>could have caused the error, but no errors are logged. The only thing I could 
>find in the logs is in the commons daemon log file:
>[10860] Apache Commons Daemon procrun ( 32-bit) started.
>[10860] Debugging 'tomcat9' service...
>[10860] Starting service...
>I also tried running Tomcat9 through the executable (tomcat9.exe) and get the 
>error: "Apache Commons Daemon Service Runner has stopped working." I have also 
>tried manually installing Tomcat9 through the 32-bit Windows zip and keep 
>having the same errors as installing it through the installer. When I tried 
>using the 64-bit version of Tomcat 9.0.24, it seems to work fine and I'm able 
>to launch it as a service, which leads me to belive that something maybe wrong 
>with the 32-bit version only. I'm using AdoptJDK 12.0.2+10 

>>Here's your problem. See my post to this list from July 26, 11:32 and earlier 
>>to which nobody has replied so far


>>The OpenJdk installers don't configure the registry the same way as as Java 8 
>>did. procrun doesn't cope with it.

>>Workaround is to mess with JAVA_HOME or to install Java 8.

>>procrun needs to be fixed.


Thanks for the response Michael. I do have JAVA_HOME set as this is a required 
step to manually install Tomcat9, otherwise it fails to find the JDK, which is 
described in the post you linked. I think my issue maybe different since this 
only happens with Tomcat 9.0.24 32-bit version specifically. As I mentioned 
earlier, I did try Tomcat 9.0.24 64-bit version with the 64-bit version of 
AdoptOpenJDK 12.0.2+10 and Tomcat9 works and runs as a service. Currently I do 
have Tomcat 9.0.22 32-bit running with AdoptOpenJDK 12.0.2+10 32-bit, so I 
don't think this issue is the same as mine. 

Do please keep in mind that this issue only occurs with Tomcat 9.0.24 32-bit as 
if I use a previous 32-bit version of Tomcat9, Tomcat9 works just fine with no 

To unsubscribe, e-mail: users-unsubscr...@tomcat.apache.org
For additional commands, e-mail: users-h...@tomcat.apache.org

Reply via email to