Add the provider you want in lib folder as well or in your webapp
dependencies - both work.

Le 16 sept. 2016 16:52, "Patel, Sanjay" <sanjay.pa...@nemours.org> a écrit :

> Thank you for quick response. Where to update provider in Tomee? I already
> see openjpa-2.4.0.jar in lib. Please advise.
>
> -----Original Message-----
> From: Romain Manni-Bucau [mailto:rmannibu...@gmail.com]
> Sent: Thursday, September 15, 2016 2:59 PM
> To: users@tomee.apache.org
> Subject: Re: InvalidDataAccessApiUsageException
>
> Only for resource local persistence unit yes upgrading the api and
> provider. For managed units upgrade the provider on tomee 7
>
> Le 15 sept. 2016 20:54, "Patel, Sanjay" <sanjay.pa...@nemours.org> a
> écrit :
>
> > Is there a way I can use JPA 2.1 implementation with Tomee 1.7.2? I
> > get below error.
> >
> > HTTP Status 500 - Request processing failed; nested exception is
> > org.springframework.dao.InvalidDataAccessApiUsageException: It seems
> > that you have the JPA 2.1 API but a JPA 2.0 implementation on the
> > classpath!; nested exception is java.lang.IllegalArgumentException: It
> > seems that you have the JPA 2.1 API but a JPA 2.0 implementation on the
> classpath!
> >
> > Thanks,
> > -Sanjay
> >
>

Reply via email to