Currently when I run the mvn quickstart command provided by the quickstart
web page, maven complains:


...
[INFO] [archetype:create]
[INFO] Archetype repository missing. Using the one from
[org.apache.wicket:wicket-archetype-quickstart:1.3.0-beta3 ->
http://repo1.maven.org/maven2] found in catalog internal
Define value for version: :


Where it then waits for user input. 
I wasn't sure what was going on, as this had never happened before, so i
just blindly hit return a couple of times. Of course the build then failed
with the following message:


[ERROR] BUILD ERROR
[INFO]
------------------------------------------------------------------------
[INFO] The archetype generation must be configured here


I found that if i entered "1.3.1" where it asked for a "value of version:"
and then "com.yournamehere" where it asks for "value for package:" then my
quickstart project was created successfully with the following log:


Define value for version: : 1.3.1
Define value for package: : com.myfrikinpackage
Confirm properties configuration:
groupId: com.mycompany
artifactId: myproject3
version: 1.3.1
package: com.myfrikinpackage
 Y: : y
[INFO]
----------------------------------------------------------------------------
[INFO] Using following parameters for creating OldArchetype:
wicket-archetype-quickstart:1.3.1
[INFO]
----------------------------------------------------------------------------
[INFO] Parameter: groupId, Value: com.mycompany
[INFO] Parameter: packageName, Value: com.myfrikinpackage
[INFO] Parameter: basedir, Value: /Users/oli/temp
[INFO] Parameter: package, Value: com.myfrikinpackage
[INFO] Parameter: version, Value: 1.3.1
[INFO] Parameter: artifactId, Value: myproject3
[INFO] ********************* End of debug info from resources from generated
POM ***********************
[INFO] OldArchetype created in dir: /Users/oli/temp/myproject3
[INFO]
------------------------------------------------------------------------
[INFO] BUILD SUCCESSFUL
[INFO]
------------------------------------------------------------------------


A bit of googling would suggest this is a maven issue, see: 
http://www.nabble.com/Archetype-repository-missing-and-asking-for-a-version-and-package-td15446552s2369.html
http://www.nabble.com/Archetype-repository-missing-and-asking-for-a-version-and-package-td15446552s2369.html
 


on the appfuse mailing list, someone is having the same problem. I have
tried clearing the offending part of my local repos, but I still can't run
the command without some user input.


The solution is very simple, but its not immediately obvious, so may put off
new users (I discovered it trying to convince a collegue how easy it was to
get up and running on Wicket, which was slightly embarrassing). Is any one
else experiencing this, or know what is going on?


Oli 
-- 
View this message in context: 
http://www.nabble.com/Wicket-Quickstart-maven-archetype---%22Archetype-repository-missing%22-tp15481228p15481228.html
Sent from the Wicket - User mailing list archive at Nabble.com.

Reply via email to