Thanks. Had a million problems yesterday, thought it was because I ran on a windoze box.

Raphaël Piéroni wrote:
This is because of the recent release of maven archetype 2.0-alpha-1 release.

Please consider calling the old plugin version the time for the maven
team to fix the problem.

mvn org.apache.maven.plugins:maven-archetype-plugin:1.0-alpha-7:create ...



2008/2/14, OliZilla <[EMAIL PROTECTED]>:
 Currently when I run the mvn quickstart command provided by the quickstart
 web page, maven complains:

 [INFO] [archetype:create]
 [INFO] Archetype repository missing. Using the one from
 [org.apache.wicket:wicket-archetype-quickstart:1.3.0-beta3 ->] found in catalog internal
 Define value for version: :

 Where it then waits for user input.
 I wasn't sure what was going on, as this had never happened before, so i
 just blindly hit return a couple of times. Of course the build then failed
 with the following message:

 [INFO] The archetype generation must be configured here

 I found that if i entered "1.3.1" where it asked for a "value of version:"
 and then "com.yournamehere" where it asks for "value for package:" then my
 quickstart project was created successfully with the following log:

 Define value for version: : 1.3.1
 Define value for package: : com.myfrikinpackage
 Confirm properties configuration:
 groupId: com.mycompany
 artifactId: myproject3
 version: 1.3.1
 package: com.myfrikinpackage
  Y: : y
 [INFO] Using following parameters for creating OldArchetype:
 [INFO] Parameter: groupId, Value: com.mycompany
 [INFO] Parameter: packageName, Value: com.myfrikinpackage
 [INFO] Parameter: basedir, Value: /Users/oli/temp
 [INFO] Parameter: package, Value: com.myfrikinpackage
 [INFO] Parameter: version, Value: 1.3.1
 [INFO] Parameter: artifactId, Value: myproject3
 [INFO] ********************* End of debug info from resources from generated
 POM ***********************
 [INFO] OldArchetype created in dir: /Users/oli/temp/myproject3

 A bit of googling would suggest this is a maven issue, see:

 on the appfuse mailing list, someone is having the same problem. I have
 tried clearing the offending part of my local repos, but I still can't run
 the command without some user input.

 The solution is very simple, but its not immediately obvious, so may put off
 new users (I discovered it trying to convince a collegue how easy it was to
 get up and running on Wicket, which was slightly embarrassing). Is any one
 else experiencing this, or know what is going on?


 View this message in context:
 Sent from the Wicket - User mailing list archive at

Nino Martinez Wael
Java Specialist @ Jayway DK
+45 2936 7684

To unsubscribe, e-mail: [EMAIL PROTECTED]
For additional commands, e-mail: [EMAIL PROTECTED]

Reply via email to