I am trying to debug an issue and am trying to step into wicket
from my project.  However, the line numbers are not matching
up with the source I have.  I've done this several times with other
projects and this is indicative of having the wrong version of the 
source vs. the jar file.

I am using eclipse version 3.5.0.v20090611a.  I'm also using
jdk1.6.0_14.

My project is setup as a java web project and I have a webapp/
WEB-INF/lib dir with my jars.  These include wicket-1.4.3.jar, 
wicket-extensions-1.4.3.jar, and wicket-datetime-1.4.3.jar.  If I
remove the wicket jar, the project can no longer identify any
of the org.apache.wicket.* imports.  This tells me that it isn't
getting a reference to derived classes.

If I then either put the wicket jar back and set the source to the
wicket-sources.jar or simply link to the 
apache-wicket-1.4.3\src\wicket\src\main\java, I still get the same
result.

As an example, when I CTRL-click on setDefaultModelObject(), it
takes me to Component.class line 3022.  I can see it going to
wicket-1.4.3.jar org.apache.wicket.Component in my Package 
Explorer.  However, when I actually run the code and step into
that method (having attached the wicket-sources.jar), the method
setDefaultModelObject is actually on line 3031.

I've gone into the wicket src dir for wicket 1.4.3 and built the wicket
jar and sources and pulled them from the target dir and still get the
same results.

Can anybody offer any insight into this?


---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscr...@wicket.apache.org
For additional commands, e-mail: users-h...@wicket.apache.org

Reply via email to