What error? Next time post the stack :)

On Thu, Apr 15, 2010 at 5:47 PM, Steven Haines <lyg...@yahoo.com> wrote:

> Hi,
>
> I am at a point where I need to upgrade my application from Spring 2.5.6 to
> Spring 3.0.1.RELEASE. I have a working application and when I update Spring,
> I see the following exception on deployment:
>
> Caused by:
> org.springframework.beans.factory.BeanCurrentlyInCreationException: Error
> creating bean with name 'sessionFactory': FactoryBean which is currently in
> creation returned null from getObject
>    at
> org.springframework.beans.factory.support.FactoryBeanRegistrySupport.doGetObjectFromFactoryBean(FactoryBeanRegistrySupport.java:157)
>    at
> org.springframework.beans.factory.support.FactoryBeanRegistrySupport.getObjectFromFactoryBean(FactoryBeanRegistrySupport.java:109)
>    at
> org.springframework.beans.factory.support.AbstractBeanFactory.getObjectForBeanInstance(AbstractBeanFactory.java:1387)
>
>
> I've simplified my Hibernate configuration to:
>
>    <bean id="sessionFactory"
> class="org.springframework.orm.hibernate3.annotation.AnnotationSessionFactoryBean">
>        <property name="dataSource" ref="dataSource" />
>        <property name="hibernateProperties">
>            <props>
>                <prop
> key="hibernate.dialect">org.hibernate.dialect.Oracle10gDialect</prop>
>                <prop key="hibernate.hbm2ddl.auto">validate</prop>
>            </props>
>        </property>
>        <property name="packagesToScan">
>            <list>
>                <value>com.mycompany.model</value>
>            </list>
>        </property>
>    </bean>
>
> Finally, here is the dependency list in Maven for my Spring and Hibernate
> libraries with wicket.version=1.4.7 and spring.version=3.0.1.RELEASE:
>        <dependency>
>            <groupId>org.apache.wicket</groupId>
>            <artifactId>wicket-spring</artifactId>
>            <version>${wicket.version}</version>
>        </dependency>
>        <dependency>
>            <groupId>org.springframework</groupId>
>            <artifactId>org.springframework.context</artifactId>
>            <version>${spring.version}</version>
>        </dependency>
>        <dependency>
>            <groupId>org.springframework</groupId>
>            <artifactId>org.springframework.core</artifactId>
>            <version>${spring.version}</version>
>        </dependency>
>        <dependency>
>            <groupId>org.springframework</groupId>
>            <artifactId>org.springframework.web</artifactId>
>            <version>${spring.version}</version>
>        </dependency>
>        <dependency>
>            <groupId>org.springframework</groupId>
>            <artifactId>org.springframework.web.servlet</artifactId>
>            <version>${spring.version}</version>
>        </dependency>
>        <dependency>
>            <groupId>org.springframework</groupId>
>            <artifactId>org.springframework.beans</artifactId>
>            <version>${spring.version}</version>
>        </dependency>
>        <dependency>
>            <groupId>org.springframework</groupId>
>            <artifactId>org.springframework.oxm</artifactId>
>            <version>${spring.version}</version>
>        </dependency>
>        <dependency>
>            <groupId>org.springframework</groupId>
>            <artifactId>org.springframework.orm</artifactId>
>            <version>${spring.version}</version>
>        </dependency>
>        <dependency>
>            <groupId>javax.servlet</groupId>
>            <artifactId>servlet-api</artifactId>
>            <version>${servlet-api.version}</version>
>            <scope>provided</scope>
>        </dependency>
>        <dependency>
>            <groupId>org.hibernate</groupId>
>            <artifactId>hibernate-core</artifactId>
>            <version>3.3.2.GA</version>
>        </dependency>
>        <dependency>
>            <groupId>javax.persistence</groupId>
>            <artifactId>persistence-api</artifactId>
>            <version>1.0</version>
>        </dependency>
>        <dependency>
>            <groupId>org.hibernate</groupId>
>            <artifactId>hibernate-annotations</artifactId>
>            <version>3.4.0.GA</version>
>        </dependency>
>
>
> I have successfully integrated Spring 3 and Hibernate in a RESTful web
> service and I have successfully integrated Wicket 1.4.7 with Spring 2.5.6
> and Hibernate, but I am seeing errors specifically with Wicket and Spring 3
> with Hibernate. Has anyone successfully integrated the three technologies?
>
> Any suggestions?
>
> Thanks!
> Steve
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: users-unsubscr...@wicket.apache.org
> For additional commands, e-mail: users-h...@wicket.apache.org
>
>

Reply via email to