Thanks Allen,

that's why i was asking in list first. So if you agree i will file a jira issue.


Am 02.01.2012 18:14, schrieb Allen Gilbert:

I ran into this problem recently and solved it by removing spaces from
directory names in my project path.  I plan to file a Jira issue at some
point, as it seems that ModificationWatcher should be able to handle file
paths with spaces...


On Mon, Jan 2, 2012 at 4:42 AM, Per Newgro<>  wrote:


If i test my app by using i get the log entry
INFO  - ModificationWatcher        - Cannot track modifications to
resource file:/D:/Dokumente%20und%**20Einstellungen/per.n/Eigene%**
If i change the HP Markup it's not reloaded.

Google only pops up an answer by igor
"not sure you can do anything about the message...just disable the logger
for that class/package..."

But disabling the log message is not solving the problem, that my markup
modifications are not re-loaded :-).
As far as i investigated this issue is a problem with the encoded path
string (%20) used to load the resource by

I'm not an expert but i think i've read a message that something changed
here (URI class or servlet-api)
but maybe someone else already solved this.

My question is - Is this a bug or can i configure something to make
resource modification watcher working?


To unsubscribe, e-mail: 
For additional commands, e-mail:

To unsubscribe, e-mail:
For additional commands, e-mail:

Reply via email to