I have been running a wicket 1.4.7  application on the aws elastic beanstalk. 
(It controls the server so the user only needs to deploy the war).  I
migrated to 1.5.5 and was able to run the application without issue in my
local environment.  However, when I deploy the 1.5.5 application to aws
after 2 minutes of running, the application is brought down with only the
following error in the logs.

Tomcat did not stop in time, killing process.
Killing Tomcat with the PID: 2514
Tomcat was killed but the PID file could not be removed.

This happens whether I am actively browsing the application or simply
opening up my main page and leaving it alone.  What I found after many
iterations of deploying is that it only happens if I use the wicket Form
object.  Its not an issue If I use WebMarkupContainer. I tested without
other components on the panel just to be sure.

Again, If I flip back to the 1.4.7 version there is no issue.  I actually
tried a test commenting out much of the Form class, but the application
would still die after about 2 minutes.

Is there anything new running in the Form class immediately from
initialization that some external process may notice?  There is likely some
aws process that is acting on the application, but it must be the result of
something that occurs by having a form on the panel.

It is very bizarre but very consistent.  I tried running wicket 6.0 beta1
and found the same issue.

thanks for any direction


--
View this message in context: 
http://apache-wicket.1842946.n4.nabble.com/1-4-7-migration-to-1-5-5-failing-on-AWS-Elastic-Beanstalk-caused-by-Form-class-tp4521002p4521002.html
Sent from the Users forum mailing list archive at Nabble.com.

---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscr...@wicket.apache.org
For additional commands, e-mail: users-h...@wicket.apache.org

Reply via email to