Looks like your dependencies are wrong. Check the 1.5 migration guide, it
should list the correct Maven coordinates to use.


On Fri, Feb 8, 2013 at 7:51 AM, Antonio muñoz alonso <
antoniovalenciasp...@hotmail.com> wrote:

> When I change the version from 1.5 wicket gives me an error.
>
> You can use the examples of http://www.highcharts.com/demo/(javascritp) and
> pass data from wicket and invoke the example.¿?
>
> ------------------------------
> CC: users@wicket.apache.org; sakai-...@collab.sakaiproject.org;
> tom.hombe...@gmail.com
> From: steve.swinsb...@gmail.com
>
> Subject: Re: [Building Sakai] Charts Wicket Sakai
> Date: Fri, 8 Feb 2013 07:04:21 +1100
> To: antoniovalenciasp...@hotmail.com
>
>
> Change the poms to list the correct dependencies for what you need, then
> adjust any compilation issues since things have changed between wicket 1.4
> and 1.5 or 6.
>
> By patch I mean send the differences in the code produced by the archetype
> and what you change so I can update the archetype.
>
> Gesendent von meinem iPhone
>
> On 07/02/2013, at 2:05, Antonio muñoz alonso <
> antoniovalenciasp...@hotmail.com> wrote:
>
> Hi.
>
> Yes, I Use
> https://confluence.sakaiproject.org/display/BOOT/Sakai+Wicket+Maven+Archetype
> .
> but not update it, I have changed the repositories of pom.xml to 1.5 but
> it gives me error.
>
> What do you mean with patch???.
>
> I'm trying to run this: 
> ://code.google.com/p/wicked-charts/<https://code.google.com/p/wicked-charts/>
>  , http://wicked-charts.appspot.com//start/?0
> fails to execute me, guess it will be the version of wicket.
>
> My wicket version is 1.4.17 and this repository use:
>
> Wicket 6.x
>
> <dependency>
>   <groupId>com.googlecode.wicked-charts</groupId>
>   <artifactId>wicked-charts-wicket6</artifactId>
>   <version>1.4.2</version>
> </dependency>
>
> Wicket 1.5.x
>
> <dependency>
>   <groupId>com.googlecode.wicked-charts</groupId>
>   <artifactId>wicked-charts-wicket15</artifactId>
>   <version>1.4.2</version>
> </dependency>
>
>
>
>
>
> Thanks.
>
>
>
>
>
>
>
>
> ------------------------------
> Date: Wed, 6 Feb 2013 10:51:49 +1100
> From: steve.swinsb...@gmail.com
> To: users@wicket.apache.org; sakai-...@collab.sakaiproject.org
> Subject: Re: [Building Sakai] Charts Wicket Sakai
>
> Hi,
>
> I wrote the Sakai Wicket Maven Archetype:
>
> https://confluence.sakaiproject.org/display/BOOT/Sakai+Wicket+Maven+Archetype
>
> Yes, you can upgrade the version of Wicket, but you'll need to adjust code
> as per the 1.5 or 1.6 upgrade guide for Wicket:
> https://cwiki.apache.org/WICKET/migration-to-wicket-15.html
> https://cwiki.apache.org/WICKET/migration-to-wicket-60.html
>
> If you do it, please send a patch and I'll update the archetype.
>
> cheers,
> Steve
>
>
> On Wed, Feb 6, 2013 at 10:42 AM, Paul Bors <p...@bors.ws> wrote:
>
> I'm not sure whick Sakai Archetype you're reffering to.
> Perhaps you can provide the maven coordinates you're using or tyring to
> use?
>
> However, if you're interested in charts and wicket take a look at the
> following or google for more:
>
> Open Flash:
> https://cwiki.apache.org/WICKET/open-flash-chart-and-wicket.html
>
> jqPlot:
>
> https://github.com/wicketstuff/core/tree/core-1.5.x/jdk-1.5-parent/jqplot-parent
>
> Or if you can afford the license for HighCharts then try Wicked-Charts
> https://code.google.com/p/wicked-charts/
>
> ~ Thank you,
>    Paul Bors
>
> On Tue, Feb 5, 2013 at 6:05 PM, Antonio muñoz alonso <
> antoniovalenciasp...@hotmail.com> wrote:
>
> > Hi.
> > I use Sakai Archetype based in wicket 1.4.17.I can update the version of
> > wicket??
> > I need to use charts, and most API are from 1.5 or 6
> > Someone I can help?
> >
> > thanks.
>
>
>
> _______________________________________________ sakai-dev mailing list
> sakai-...@collab.sakaiproject.org
> http://collab.sakaiproject.org/mailman/listinfo/sakai-dev TO UNSUBSCRIBE:
> send email to sakai-dev-unsubscr...@collab.sakaiproject.org with a
> subject of "unsubscribe"
>
>

Reply via email to