Sorry , because the server receives no event.
There is no debug output.

I think it is easy to replicate the error.
just fork bootstrap-samples :

https://github.com/l0rdn1kk0n/wicket-bootstrap/tree/master/bootstrap-samples

and add
LoginModal code :
http://pastebin.com/0qGUFvXP


And the LoginPage code :
http://pastebin.com/aDDxuZmx

The server will receive no event (fired in the LoginPage) .



2014-07-08 18:45 GMT+08:00 Martin Grigorov <mgrigo...@apache.org>:

> Then you will have to debug what happens ...
>
> Martin Grigorov
> Wicket Training and Consulting
> https://twitter.com/mtgrigorov
>
>
> On Tue, Jul 8, 2014 at 1:28 PM, smallufo <small...@gmail.com> wrote:
>
> > Yes , I am using 6.16.0
> >
> >   <properties>
> >     <wicket.version>6.16.0</wicket.version>
> >     <wicket-bootstrap.version>0.9.4</wicket-bootstrap.version>
> >     <yuicompressor.version>2.4.7</yuicompressor.version>
> >   </properties>
> >
> >
> > 2014-07-08 14:56 GMT+08:00 Martin Grigorov <mgrigo...@apache.org>:
> >
> > > I believe https://issues.apache.org/jira/browse/WICKET-5585 is
> related.
> > > Do you use Wicket 6.16.0 ?
> > >
> > > Martin Grigorov
> > > Wicket Training and Consulting
> > > https://twitter.com/mtgrigorov
> > >
> > >
> > > On Tue, Jul 8, 2014 at 4:00 AM, smallufo <small...@gmail.com> wrote:
> > >
> > > > sorry , There is no stack trace.
> > > > Because it triggers nothing , the server doesn't receive anything.
> > > >
> > > >
> > > >
> > > > 2014-07-07 14:21 GMT+08:00 Michael Haitz <michael.ha...@1und1.de>:
> > > >
> > > > > please provide the full stacktrace.
> > > > >
> > > > > cheers,
> > > > > Michael
> > > > >
> > > > > Am 06.07.2014 um 05:44 schrieb smallufo <small...@gmail.com>:
> > > > >
> > > > > > It seems working now.
> > > > > > But such removal also make theme-switching not working :
> > > > > >
> > > > > > If I enable the ThemeProvider :
> > > > > >
> > > > > >    final ThemeProvider themeProvider = new
> > > > > > BootswatchThemeProvider(BootswatchTheme.Flatly);
> > > > > >
> > > > > >
> > > > >
> > > >
> > >
> >
> settings.setJsResourceFilterName("footer-container").setThemeProvider(themeProvider);
> > > > > >
> > > > > > without "footer-container" in the BasePage
> > > > > >
> > > > > > wicket-bootstrap will throw
> > > > > >
> > > > > > WicketRuntimeException: theme does not exists: bootstrap
> > > > > >
> > > > > > at
> > > > > >
> > > > >
> > > >
> > >
> >
> de.agilecoders.wicket.themes.settings.BootswatchThemeProvider.byName(BootswatchThemeProvider.java:49)
> > > > > >
> > > > > >
> > > > > > So I could only use the native bootstrap theme now.
> > > > > >
> > > > > >
> > > > > >
> > > > > >
> > > > > > 2014-07-06 11:30 GMT+08:00 smallufo <small...@gmail.com>:
> > > > > >
> > > > > >> I found where goes wrong ,
> > > > > >> it's RenderJavaScriptToFooterHeaderResponseDecorator that causes
> > the
> > > > > >> problem.
> > > > > >>
> > > > > >> I am not familiar with wicket-bootstrap , so I mimicked
> > > > wicket-bootstrap
> > > > > >> sample's architecture :
> > > > > >>
> > > > > >>
> > > > >
> > > >
> > >
> >
> https://github.com/l0rdn1kk0n/wicket-bootstrap/tree/master/bootstrap-samples/src/main/java/de/agilecoders/wicket/samples
> > > > > >>
> > > > > >> This is my 'not' working architecture :
> > > > > >> http://pastebin.com/vB3Ek2t9
> > > > > >>
> > > > > >> After removing RenderJavaScriptToFooterHeaderResponseDecorator ,
> > > > > >> footer-container , it works fine.
> > > > > >>
> > > > > >> http://pastebin.com/kAehvaRr
> > > > > >>
> > > > > >>
> > > > > >>
> > > > > >>
> > > > > >>
> > > > > >> 2014-07-05 21:10 GMT+08:00 Francois Meillet <
> > > > francois.meil...@gmail.com
> > > > > >:
> > > > > >>
> > > > > >> Run your app in debug mode and set some breakpoint.
> > > > > >>>
> > > > > >>> eclipse
> > > > > >>>
> > > > > >>>
> > > > >
> > > >
> > >
> >
> http://www.eclipse.org/jetty/documentation/current/debugging-with-intellij.html
> > > > > >>> http://www.vogella.com/tutorials/EclipseDebugging/article.html
> > > > > >>>
> > > > > >>>
> > > > >
> > > >
> > >
> >
> http://help.eclipse.org/juno/index.jsp?topic=%2Forg.eclipse.jdt.doc.user%2Freference%2Fpreferences%2Frun-debug%2Fref-run_debug.htm
> > > > > >>>
> > > > > >>> intellij
> > > > > >>>
> > > http://www.jetbrains.com/idea/webhelp/run-debug-configurations.html
> > > > > >>>
> > > > > >>>
> > > > >
> > > >
> > >
> >
> http://www.jetbrains.com/idea/webhelp/creating-and-editing-run-debug-configurations.html
> > > > > >>>
> > > > > >>> François Meillet
> > > > > >>> Formation Wicket - Développement Wicket
> > > > > >>>
> > > > > >>>
> > > > > >>>
> > > > > >>>
> > > > > >>>
> > > > > >>> Le 5 juil. 2014 à 14:56, smallufo <small...@gmail.com> a
> écrit :
> > > > > >>>
> > > > > >>>> 2014-07-05 20:55 GMT+08:00 smallufo <small...@gmail.com>:
> > > > > >>>>
> > > > > >>>>>
> > > > > >>>>> But i still find another "id6c" or "id6d"  in the source
> code.
> > > > > >>>>>
> > > > > >>>>
> > > > > >>>> sorry typo :
> > > > > >>>>
> > > > > >>>> But i still *cannot* find another "id6c" or "id6d"  in the
> > source
> > > > > code.
> > > > > >>>
> > > > > >>>
> > > > > >>
> > > > >
> > > > >
> > > > >
> ---------------------------------------------------------------------
> > > > > To unsubscribe, e-mail: users-unsubscr...@wicket.apache.org
> > > > > For additional commands, e-mail: users-h...@wicket.apache.org
> > > > >
> > > > >
> > > >
> > >
> >
>

Reply via email to