Hi Victor

you should start by looking at this:
http://www.xwiki.org/xwiki/bin/view/AdminGuide/Installation

Now I have the same problem as you have. Here are the issues I see:

- the 0.9 database schema is not compatible with latest 1.1.1 (though
connecting 1.1rc2 to the 0.9 database works provided that you applied the
fix you refered too).

- You can export you 0.9 wiki pages by copying the script available at
http://old.xwiki.org/xwiki/bin/view/Test/ImportExport . It allows you to
create a .xar (zip formatted) package containing all your wiki

- Alternatively you can connect a 1.1 wiki to the 0.9 database (provided
you applied your fix), import the appropriate pages if necessary and
export using the 1.1 export feature. It will create the xar package
containing ALL your wiki pages and I don't see how to select only a few
pages. As far as I can see this method is equivalent to the one above and
the outcome is the same.

- I tried a fresh installation: 1) create the database in MySQL (leave it
empty) by following to the letter the excellent tutorial from the URL
above; 2) connect you 1.1.1 wiki to this new database and it will create
all the tables for you; 3) proceed with the tutorial and import all the
pages you need (I recommand at least Panels.xar); 3) Now we have a
problem: importing .xar packages coming from a 0.9 wiki does not work.
This is where I am stuck.

If you know the end of the story, I'd like to hear it ;-)

I hope that could help to some extent...

Marc

> Hi all,
>
> I've been using XWiki during this year and now I have a titanic task :
> upgrade it to XWiki 1.1
>
> Unfortunately I haven't found any document on how to upgrade, neither in
> the site nor in the list archives, so I decided to transfer the MySQL
> database to a new location (unsing mysqldump) and install XWiki 1.1 from
> scratch
> (http://www.xwiki.org/xwiki/bin/view/AdminGuide/Installation#HInstallingtheXWikiWARmanually)
>
> using MySQL 5.0 and Tomcat 6
>
> After obtaining a " *Field 'XWD_ARCHIVE' doesn't have a default value"
> error (and solved it thanks to
> http://jira.xwiki.org/jira/browse/XWIKI-1702) a more obscure error
> appears regarding some attributes and so.
>
> I decided not to follow a trial an error path, and I'm  here asking for
> some guide or guidelines to do this upgrade, or in case such a thing
> doesn't exists beg for  some help from you all, and as a thanks gift
> offer to publish a mini howto for upgrading XWiki from v0.9.x to 1.1.
>
> Thanks in advance for your help.
>
> --
> Víctor A. Rodríguez (http://www.bit-man.com.ar)
> El bit Fantasma (Bit-Man) - Algorithm junkie
> Perl Mongers Capital Federal (http://cafe.pm.org/)
> GNU/Linux User Group - FCEyN - UBA (http://glugcen.dc.uba.ar/
> _______________________________________________
> users mailing list
> users@xwiki.org
> http://lists.xwiki.org/mailman/listinfo/users
>

_______________________________________________
users mailing list
users@xwiki.org
http://lists.xwiki.org/mailman/listinfo/users

Reply via email to